vServer.sh


([N4] vnexo) #1

Hola,
En el Centos 5.6 que tenia de servidor con la nueva version 7.7 me aparece este error:

VelneoV7-vServer# ./vServer.sh status
./vServer: /lib/libc.so.6: version 'GLIBC_2.11' not found (required by ./libQtGui.so.4)
./vServer: /lib/libc.so.6: version 'GLIBC_2.9' not found (required by ./libQtCore.so.4)
./vServer: /lib/libc.so.6: version 'GLIBC_2.10' not found (required by ./libQtNetwork.so.4)
./vServer: /lib/libc.so.6: version 'GLIBC_2.9' not found (required by ./libQtGui.so.4)
¿Alguna idea?
La 7.6 funcionaba perfectamente, por otro lado estaria bien saber las dependencias de qt 4.7

Un saludo
Manolo Remohi


([N1] Pepeto) #2

Esta version incluye QT 4.7.2
y esta documentado en el informe de Cambios

un saludo
Jose Luis


([N1] polo) #3

Ya somos dos, yo tengo el CENTOS 5.5 en una maquina virtual.
Lo que he entendido es que es imposible o mucho ariesgado tener esa version de GLIBC en centos.
A ver si velneo nos comenta algo.


([N1] polo) #4

Les dejo la respuesta de velneo al suporte que he enviado:

Es normal que una décima en la versión de Velneo, la torne incompatible con un sistema operativo??

Efectivamente un cambio de una versión, como en este caso en que se cambian las versiones de las librerías utilizadas. El motivo es que algunas de las incidencias solucionadas requieren indispensablemente de esta nueva versión de las librería. Esto hace incompatible con versiones anteriores de las librerías utilizadas, como en tu caso por el sistema operativo.

Pienso que Velneo antes de hacer una compilación debería tener en cuenta estos aspectos...
Tenemos muy en cuenta esta circunstancia y por eso un cambio de este tipo no se realiza habitualmente y si no es indispensable, el ultimo cambio del estilo fue hace 2 años.
(http://velneo.es/foros/topic/version-glibc_24-not-found)

Que hacemos ahora, ¿cambiamos de hosting?, ¿cambiamos de sistema operativo?
Si te es necesario utilizar ya la versión Velneo V7 7.7 necesitas un sistema operativo que soporte la versión indica de las librerías GLIBC. Ya sea una actualización del sistema Centos u otro compatible.


([N4] vnexo) #5

Hola,

A mi me ocurre lo mismo. La empresa de hosting ofrece centos.
Voy a ver si hay manera de en un centos subirle el animo hasta glibc 2-11, si no mal. tocara cambiar a Fedora.
Centos 6 traer 2.12 pero es beta aun.
Si ha alguien mas le ocurre y lo ha solucionado que cuente. Yo si lo soluciono lo publicare.

un saludo
Manolo


([N4] innovadb) #6

Si Centos 6 trae la 2.12, teneis otra distro que os vale, y tambien es un clon de RedHat.

http://www.scientificlinux.org/

Un saluco


([N1] Giuseppe::Komenco) #7

He oido hablar bien de scientific...llevo semanas queriendo probarla...


([N4] innovadb) #8

Al final es igual de buena que centos o rhel, lo que pasa es que en centos parece que tienen problemas internos y las cosas no funcionan como deberian.

Yo tengo esta instalada y lo que no conseguí fué que me funcionara teamviewer, por lo demás perfecto. (v7 no la probé todavia)

Un saludo


([N4] vnexo) #9

Hola

Gracias por el aporte. Pero el problema no es mio. Es el datacenter el que me da a elegir entre centos o windows. Esta claro que debo actualizar centos, y esto siempre es un trastorno, mas si la maquina ademas sirve correos, webs, dns etc-

un saludo
Manolo remohi


([N1] Giuseppe::Komenco) #10

@vnexo

No, si lo que está claro es que tienes un marrón de cuidado. Yo estoy igual, ayer o antes de ayer por fin terminé de configurar el VPS de un cliente, y ahora me va a tocar rehacerlo todo con Debian 6

Te acompaño en el sentimiento.


([N4] vnexo) #11

Amen, jaja
Lo tomaremos con animo. Veré si hay una migración fácil de centos 5.6 a FC12 que en FC12 si va. Pero efectivamente marrón improductivo.

Un saludo
Manolo


([N1] ppcamp) #12

Yo he probado con LinuxMint 10 (basada en ubuntu, aunque hay otra versión basada en Debian) en una imagen de virtualbox y (en principio) funciona correctamente.


([N1] Giuseppe::Komenco) #13

El tema es, que lo que se comenta en este hilo, es a nivel de Servidor, y Linux Mint no es una distribución para tener en un servidor, si no en ordenadores de escritorio.

La inmensa mayoría de proveedores, suelen ofrecer Windows, o principalmente CentOS o RHEL o Debian, y ninguna de las nombradas de Linux (a excepción de Debian, y en su versión 6, lanzada hace poco) incorporan una librería de glibc tan actualizada (por cuestiones de estabilidad y bugfixes) como la necesaria por la nueva versión de Velneo, lo que implicaría realizar un cambio completo del sistema, y ésto, en un servidor en producción, donde podamos tener servidores DNS, Web, correo etc.. perfectamente configurados, es un gasto de tiempo considerable, migrarlo todo y reconfigurarlo.


([N1] ppcamp) #14

Cierto Giuseppe, como tenía en la cabeza el empezar a usar el vDevelop desde Linux para programar, por eso estaba probando esa distribución.
Para el servidor, he probado con la Debian 6 y solo he tenido que instalarle el paquete libglib2.0.0
De todas formas, como comentáis, es un trabajo muy engorroso el tener que cambiar de S.O. en servidores en producción.

Un saludo.


([N1] Valdes) #15

Divide y vencerás.....
,
www.sologigabit.com
,
Destinas tus recursos a lo que necesites y una versión para cada cosa:
1 sistema Ubuntu para vserver
1 sistema win para vserver 6X
1 sistema X para dns, web, correo y demás...
.
Saludos
Mario Valdés Caso