vServer, se detiene el servicio


([N4] informatica) #1

El vServer se me ha detenido 2 veces sin dar ningún tipo de mensaje. He reiniciado el servicio.

Estaba editando una caja de datos cuando pasó y ahora no me permite grabar dicha caja. He comprobado en el vServer la tiene con el iconito en rojo, es decir no bloqueada.


([N4] rcueto.velneo) #2

Hola:

 

Tienes que desproteger la caja. Pincha aquí para saber cómo hacerlo.

 

Un saludo.


([N4] informatica) #3

Como puedes leer en mi mensaje anterior, la caja NO ESTA PROTEGIDA, eso fue lo primero que miré.


([N4] rcueto.velneo) #4

Hola:

 

Entonces es que el vDevelop ha perdido la conexión con vServer. Sin cerrar vDevelop, vuelve a conectarte con el servidor e intenta grabarla nuevamente.

 

Un saludo.

 

 


([N4] informatica) #5

Ya lo he intentado, varias veces, sigue dando el mismo error, No se puede Grabar la caja xxxxxx

Me ha pasado ya 3 veces

desde que se ha producido la primera caida el vServer se está deteniendo cada poco. Aparentemente se produce al dar de baja varios registros seguidos de una misma tabla (una tabla muy pequeña, 20 registros)


([N4] rcueto.velneo) #6

Hola:

 

Si aún así no puedes grabar la caja, abre otra sesión de vDevelop, conéctate con vServer, crea una nueva caja, copia y pega de la otra aquellos objetos que habías modificado y/o creado que no están en la última versión guardada de la misma.
 
Una vez hecho esto, cierra la otra sesión de vDevelop, vuelve a cargar la caja y actualiza los objetos copiados anteriormente.
 
En cuanto al error que dices que está provocado por un proceso, si se trata de un servidor local, si quieres puedes enviar por correo las cajas necesarias para probarlo en laboratorio e intentar así reproducirlo. Si se trata de un servidor en la nube, envíanos los datos de acceso a las cajas.
 
Un saludo.


([N4] informatica) #7

Es un servidor en la nube, esta noche borrare todos los datos. Mañana contaré algo. Ahora tenemos el seminario.


([N4] informatica) #8

Da igual que esté el local que en la nube. Cuando lanzas un proceso que borra varios registros, el servidor se cae. Si la tabla no tiene historicos el borrado se hace bien, pero si la tabla tiene historicos y tenemos declarado un evento de tabla: Anterior a una baja de ficha, el tipico: Cargar Plurales->Recorrer Lista Eliminando Fichas el servidor se cae.

He probado con Cargar Plurales->Recorrer lista eliminando fichas sin desactualizar, en este caso se borran todos los registros de la tabla, pero NO SE BORRAN LOS HISTORICOS.

Es fundamental que contempleis el caso de que un servidor se va a caer y te va a dejar cajas de datos y aplicaciones sin grabar. Se debería poder reconectar con el servidor y grabar las cajas que se están editando. Ese sistema de crear nuevas cajas y mover objetos no es operativo.


([N4] rcueto.velneo) #9

Hola:
 
Hemos estado probando el tema del borrado de registros en triggers, y si bien hemos comprobado una serie de comportamientos anómalos –como el que Vd. describe de que en algunas circunstancias no se borran los históricos- en ningún caso hemos podido provocar el error en Velneo vServer; no obstante, seguiremos investigando.
 
En lo que se refiere al guardado de un mapa desde vDevelop tras un error inesperado de vServer, ha sido incluido en nuestro sistema de gestión de incidencias con el código de referencia: 1275.
 
Con este código puedes hacer referencia a la incidencia en el caso de que quieras conocer su estado en el futuro.
 
Queremos agradecer de nuevo tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.
 
Un saludo.