vServer en VPS hyper-V


([N1] Spicer) #1

Amigos,

Hice un despliegue en producción de vServer en una VPS de un datacenter que funciona con Hyper-V (Win 2008 R2), y el resultado es…
…UN DESASTRE…!

El vClient se queda pegado en forma recurrente, pero el vServer no deja de funcionar.
La VPS tiene 1 Gb de RAM y está usada en un 60%; el vServer consume sólo 52 Mb y no muestra aumentos cuando los vClient se quedan pegados

No sé si esto se debe a que la VPS tiene muy poca memoria o qué, pero me está causando una de dolores de cabeza que ni les cuento… ¿tienen algo que compartir al respecto? hasta ahora había puesto vServers en maquinas Wnidows Server, pero sin virtualizar, y el resultado era genial.

Saludos


([N4] eic) #2

Hola.

No conozco mucho la arquitectura Hyper-V, nosotros trabajamos con VMWare.

En cualquier caso, pienso que tener un servidor (virtual o no virtual) con 1 GB de RAM es muy, muy poco. Como mínimo, pon 4 GB, o mejor, 8 GB. Y tendrás que ver si el procesador tiene la capacidad suficiente. Algunas de esas máquinas virtuales están pensadas para servicios web, que requieren muy poco procesamiento, pero vServer es otra historia.


([N1] wikan) #3

Yo los mayores problema de lentitud que he notado en los vClient siempre han sido problemas de red.
Hay una pequeña diferencia entre abrir el vClient usando un nombre y usando la ip directamente.

Revisa que el servidor es completamente accesible, que no tengas problemas de redireccionamiento.


([N1] Spicer) #4

Estimados,

Finalmente me aburrí y cambié los usuarios desde la VPS a otro servidor físico que tengo por ahí. Mi impresión es que efectivamente el cuello de botella estaba en el acceso de red

De todos modos, me parece que con 2 Gb debiera estar bien, pues VServer no consume más de 150 Mb de RAM