vSendMail - No funcionan cuentas que no sean de gmail


([N2] overBCN) #1

Hola,
He instalado el componente vSendMail y todo funciona bien, excepto cuando configuras cuentas que no sean de gMail. La configuración de cuentas de dominio propio NO funcionan.
La cuenta requiere tener activo SSL ó StartTLS y requiere autenticación. Lo he probado con todas las combinaciones, pero siempre devuelve “Tiempo de espera expirado”. Esto sucede tanto en Mac como en Windows.
En las cuentas de correo de mi dominio he configurado que el protocolo sea StartTLS (y también sin él), pero nada de nada.
Alguien tiene instalado este componente?, alguna solución?, hay alguna forma mas de enviar mails multiplataforma sin tener que instalar software adicional?
Un saludo.


([N4] jmgonzalez.velneo) #2

Buenas

Todas las pruebas que hicimos siempre funcionó, tanto con dominios propios, de gmail, de google apps, de yahoo y de hotmail.

De todas maneras, para salir de dudas, intenta primero el envio directamente desde línea de comandos usando el ejecutable que va como adjunto y que debes tener en la caché del vclient.

Saludos


([N1] tcvsi) #3

Hola Luis:

yo utilizo vsendmail sin problemas con cualquier cuenta.

Hasta ahora sin problemas


([N2] overBCN) #4

Hola,
Lo hago desde la linea de comandos (windows y mac), me pide el servidor SMTP, from, TO y SUBJECT. Me devuelve el siguiente error:

SMTP server address/IP: mail.overall-bcn.com
From: overall@overall-bcn.com
To: ganapias@gmail.com
Subject: Pruebas
Error: Connection to mail.overall-bcn.com:25 timed out after 5 seconds
Error: Could not connect to SMTP server “mail.overall-bcn.com” at port 25
Could not send mail
logout

Si lo pruebo con cuentas de gmail, me devuelve el siguiente error:

SMTP server address/IP: smtp.gmail.com
From: ganapias@gmail.com
To: overall@overall-bcn.com
Subject: Pruebas
Error: MAIL FROM failed: ‘530 5.7.0 Must issue a STARTTLS command first. bj5sm15427970wib.3 - gsmtp’
Could not send mail
logout

Desde el mismo componente, sin tocar nada de código, solo puedo enviar con cuantas de gmail.

Alguna solución? ya no se que hacer.

Saludos y gracias


([N4] jmgonzalez.velneo) #5

Buenas

Deberías marcarte como objetivo poder enviar desde línea de comandos. Una vez conseguido eso, hacerlo desde el componente es fácil.

Revisa los posibles parámetros de mailsend, ya que hay uno que te permite hacer un verbose. Seguramente te dará que no puede conectar con ese servidor. Parece un tema de firewall. Intenta hacer un telnet a ese host y puerto a ver si te responde. Desde el mismo equipo puedes usar esa cuenta desde Outlook o similar?

Saludos


([N2] overBCN) #6

Gracias por tu rápida respuesta,

Hago TELNEt y encuentra el servidor :

iMac-de-Luis:~ ganapias$ telnet mail.overall-bcn.com 25
Trying 82.98.160.157…

Los mails los tengo configurados en el mismo equipo (cliente Mail - OSX) y funcionan perfectamente.

He desactivado el firewall, hi todo sigue igual.

Insisto, con cuentas de gmail, funciona.


([N4] jmgonzalez.velneo) #7

Intenta lanzar el comando mailsend con el parámetro verbose y pega aquí el resultado (cuidado con no publicar claves)

Saludos


([N1] intelpric) #8

Saludos cordiales…

Cuidado con la actualización de la 7.15 algunas librerias dejaron de ser compatible con con velneo v7…

El equipo de soporte trabaja en ello…

At: Jpablo
http://vgestoradmin.blogspot.com/
vgestor@gmail.com


([N4] jmgonzalez.velneo) #9

Buenas

Este componente no usa librerías externas. Lo que hace es habilitar una serie de funciones que llaman a un .exe.

Saludos


([N1] wikan) #10

Buenas, en su día tuve problemas con blat, me pasaba lo mismo.
La solución fue subirle el timeout por defecto al conectar con el servidor. Supongo que mailsend, tendrá una parámetro para configurar el timeout.


([N2] overBCN) #11

Hola,

Perdona, pero como lanzo el comando mailsend con el parámetro verbose?

Saludos


([N4] jmgonzalez.velneo) #12

Si ejecutas “mailsend.exe -help” te sale esto

Version: @(#) mailsend v1.16

Copyright: GNU GPL. It is illegal to use this software for Spamming

(Compiled with OpenSSL 1.0.0g 18 Jan 2012)
usage: mailsend [options]
Where the options are:
 -smtp hostname/IP*    - Hostname/IP address of the SMTP server
 -port SMTP port       - SMTP port
 -d    domain          - domain name for SMTP HELO/EHLO
 -t    to,to..*        - email address/es of the recipient/s
 -cc   cc,cc..         - Carbon copy address/es
 +cc                   - do not ask for Carbon Copy
 -bc   bcc,bcc..       - Blind carbon copy address/es
 +bc                   - do not ask for Blind carbon copy
 +D                    - don not add Date header
 -f    address*        - email address of the sender
 -sub  subject         - subject
 -l    file            - a file containing the email addresses
 -attach file,mime_type,[i/a] (i=inline,a=attachment)
                       - attach this file as attachment or inline
 -cs   character set   - for text/plain attachments (default is us-ascii)
 -M    "one line msg"  - attach this one line text message
 -name "Full Name"     - add name in the From header
 -v                    - verbose mode
 -V                    - show version info
 -w                    - wait for a CR after sending the mail
 -rt  email_address    - add Reply-To header
 -rrr email_address    - request read receipts to this address
 -ssl                  - SMTP over SSL
 -starttls             - Check for STARTTLS and if server supports, do it
 -auth                 - Try CRAM-MD5,LOGIN,PLAIN in that order
 -auth-cram-md5        - use AUTH CRAM-MD5 authentication
 -auth-plain           - use AUTH PLAIN authentication
 -auth-login           - use AUTH LOGIN authentication
 -user username        - username for ESMTP authentication
 -pass password        - password for ESMTP authentication
 -example              - show examples
 -ehlo                 - force EHLO
 -info                 - show SMTP server information
 -help                 - shows this help
 -q                    - quiet

Ahí te dice que puedes añadir el parámetro -v para el modo verbose.

Saludos


([N2] overBCN) #13

Hola,

Desde la app le he pasado el parámetro que indicas:

fun:SET_PARAM@vSendMail.dat(PARAMS, “-v”, “”)

y el mensaje que devuelve lo adjunto en la imagen.

Saludos, Luis.




([N4] jmgonzalez.velneo) #14

Luis, te recomiendo que primero lo hagas desde línea de comandos. En Windows abres una consola con cmd.exe y vas hasta el directorio caché de v7. Yo he probado a ejecutarlo con estos parámetros:
mailsend -smtp mail.overall-bcn.com -ssl -port 465 -v -info

y me conecta bien. Se ve que ese smtp necesita conexión ssl por el puerto 465. Prueba así, pero siempre primero desde línea de comandos. Cuando te funcione por línea de comandos ya añades los parámetros necesarios al componente.

Saludos


([N2] overBCN) #15

Gracias #jmgonzalez,

Te devuelvo la info que me devuelve, es la misma que desde la app.

Saludos, Luis



([N3] pacosatu) #16

Hola Luis.

Me parece que tienes un problema de conectividad con el servidor SMTP y no tiene nada que ver con mailsend.exe.

Revisa el Firewall, el Antivirus, el Proxy si lo hay, el Router …
Desactiva todo momentáneamente y pruebas.

Saludos
Paco Satué


([N4] jmgonzalez.velneo) #17

Estoy con Paco. Parece un problema de antivirus o de firewall que estén bloqueando a mailsend.exe, sobre todo porque a mi con el mismo comando si me conecta correctamente con tu servidor smtp.

Saludos


([N2] overBCN) #18

Ok, gracias a los dos.
Lo probaré, pero lo extraño es que con cuentas de gmail funciona a la perfección.
Saludos


([N1] wikan) #19

@Palomo, yo me reitero en lo que te comente, aumento el tiempo de timeout a ver que pasa
-ct 60
5 segundos puede ser poco para tu servidor


([N1] wikan) #20

Me edito @Palomo, la versión 1.17 es la que tiene el comando -ct