vReport Código de Barras


([N3] GSI) #1

Buenas, estoy intentando poner unos códigos de barras en algunos informes, pero no logro que aparezcan, lo ponga como lo ponga (entiendo que lo normal es EAN), entonces no se si es que hay que hacer algo en especial o poner algo en otro sitio, (todos los demas datos los relleno correctamente pero nunca aparece el código de barras).
Aver si alguien sabe algo, gracias.


([N4] velavisual) #2

Según el manual que he podido ver de vReport, dice:

Códigos de barras: Los informes externos permiten imprimir códigos de barras haciendo uso del componente externo Zint. Los informes externos admiten más de 50 tipos de códigos de barras: Code 128, Data Matrix, USPS OneCode, EAN-128, UPC/EAN, ITF, QR Code, Code 16k, PDF417, MicroPDF417, LOGMARS, Maxicode, GS1 DataBar, Aztec, Composite Symbols y muchos más.

¿Has instalado la aplicación ZINT que viene incluida?


([N3] GSI) #3

Si, si, lo tengo instalado y correctamente configurado, pero no congiso que lo imprima ni lo muestre en pantalla…
Adjunto una captura con la congifuración del código de barras, por si resulta mas esclarecedor, gracias.



([N4] amadis) #4

Si no me equivoco, a la hora de pasarle el dato, ahí te sobra el $D{}, solamente tienes que poner el campo…


([N3] GSI) #5

He tenido este tema un poco aparcado, pero ahora me vuelve a hacer falta de nuevo.
Instalando zint, configurando todo correctamente en el informe y demás, no hay manera de que se visualice…
Como dice amadis solo le paso el campo sin lo demás y aún así tampoco funciona…
Alguien sabe como va o lo tiene funcionando correctamente? Un saludo.


([N3] GSI) #6

Me autorrespondo, el problema era que había que, después de instalar el zint, decirle donde esta el .exe de la instalación a vreport para que lo pueda utilizar.
Con eso en principio ya se muestran e imprimen los códigos de barras.
Un saludo.


([N4] ns) #7

¿Y en mac como hacemos los códigos de barras?
ZINT no sirve…

alguien lo ha conseguido?

Gracias y saludos


([N3] frugulletti) #8

Un saludo amigos, justo tengo el mismo problema con el tema de los codigos de barra, en la previsualización me sale “Error d código de barras”, ya instalé el Zint pero no estoy seguro de en donde debo indicarle al vReport la ruta de instalación del mismo, coloqué la ruta en directorios por defecto, pero sigue igual.
Si me pueden dar una mano al respecto, se los agradecería…


([N4] jon.infortic) #9

Buenas tardes

Yo he añadido el menú de vReport en la configuración de mi aplicación, si despliegas este menú, en Principal/Configuración de Velneo vReport/Configurar senda de instalación de zint, es donde se guarda esta ruta.

La ruta en cuestión se guarda en el registro, en sistemas operativos de escritorio en principio no hay problemas, pero en Windows 2012 no he conseguido que funcione.
Saludos.


([N4] eduardo.chaparro) #10

Buenas tardes Sres.

Estoy trabajando con la impresión de codigo de barras, ya logre hacerla funcionar en Windows perfectamente, sin necesidad de mandar al cliente a instalar nada, todo lo hace mi solución internamente.

Ahora bien, estoy tratando de hacerlo en linux, sin embargo, no ha sido posible, ya tengo instalado lo que en el manual de zint recomienda que es el CMAKE, build-essential y las librerías libpng y libpng-dev… He realizado varias pruebas asignándole a la configuración del vReport la senda donde esta todo esto “/usr/local/lib/” también la carpeta zint que se creo al descomprimir el tarball, y no logro hacer que el vReport imprima el código de barras… Alguien me puede ayudar con esto?