vModApache en Linux 16.04


([N3] tony.galdamez) #1

Saludos a todos,
He estado trabajando en la instalación de vModApache en un servidor Linux 64 bits en AWS, he seguido la poca documentación que velneo ofrece para ello y investigando después de varias pruebas he logrado que apache ya se conecte a velneo.
He desarrollado una aplicación web que devuelve diferentes JSON, es una aplicación web que tiene de backend a Velneo/php y de front end html, javascript.
La aplicación en mi servidor local funciona sin problemas pero al tratar de acceder a llamar los procesos en la aplicacion en el servidor Linux, de forma directa:

http://IP_SERVIDOR/gestion/index.pro

This page isn’t working
184.*.*.*** didn’t send any data.
ERR_EMPTY_RESPONSE

Al revisar el vadmin, el vmodapache si esta conectado al servidor y consume su usuario pero no logro conseguir que me responda como deberia.
En el log de Apache me dice lo siguiente:

[Sat Jul 07 07:05:39.941522 2018] [core:notice] [pid 2518] AH00051: child pid 4087 exit signal Segmentation fault qt.network.ssl: QSslSocket: cannot resolve SSLv2_client_method qt.network.ssl: QSslSocket: cannot resolve SSLv2_server_method [Sat Jul 07 07:06:40.002752 2018] [core:notice] [pid 2518] AH00051: child pid 4089 exit signal Segmentation fault
qt.network.ssl: QSslSocket: cannot resolve SSLv2_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv2_server_method

Se supone que al poder levantar el apache con éxito y consumir el usuario en el servidor de Velneo ya debería de funcionar, cabe aclarar que si utilizo el vclient para acceder a la instancia de aplicación si funciona bien y todo trabaja como debe el problema solo es con el vModApache.

Todas las librerías y dependencias necesarias están actualizadas a sus versiones mas recientes.
APACHE
Server version: Apache/2.4.18 (Ubuntu)
Server built: 2018-06-07T19:43:03
PHP
PHP Version 7.0.30-0ubuntu0.16.04.1

vModApache y vServer
Ver. 23.1.3

Alguien ha tenido éxito con el utilizar el vModApache en LINUX? cualquier ayuda sera muy agradecida.

La guía que seguí fue esta https://doc.velneo.es/instalacion-y-configuracion-vmodapache.html