Velneo y Linux


([N1] glpunzi.lordzealon) #1

Hola a todos,

He descargado para probar v7.4, y estoy intentando ejecutar tanto vDevelop, como vAdmin sin éxito.

Desde GUI el script no arranca, desde consola, revela:

glpunzi@giu:~/tmp/velneo/VelneoV7-vAdmin$ sh vAdmin.sh
vAdmin.sh: line 50: /home/glpunzi/tmp/velneo/VelneoV7-vAdmin/vAdmin: No such file or directory
vAdmin.sh: line 50: /home/glpunzi/tmp/velneo/VelneoV7-vAdmin/vAdmin: Success
glpunzi@giu:~/tmp/velneo/VelneoV7-vAdmin$

OS: Slackware 13.1 64bits

Alguna idea?


([N1] B-Soft-2) #2

Hola,

Prueba darle permisos de ejecución al fichero vAdmin (sin .sh)

# chmod o+x vAdmin

 

 

Saludos,


([N1] glpunzi.lordzealon) #3

No, si ya tiene...

 

glpunzi@giu:~/VelneoV7-vClient$ ls -all
total 48288
drwxr-xr-x  3 glpunzi users     4096 2010-10-05 15:48 ./
drwx--x--x 61 glpunzi users     4096 2010-10-05 17:29 ../
-rw-r--r--  1 glpunzi users    11542 2010-06-28 09:44 License.txt
-rwxr-xr-x  1 glpunzi users  2728556 2010-06-28 09:44 libQtCore.so.4*
-rwxr-xr-x  1 glpunzi users 11122060 2010-06-28 09:44 libQtGui.so.4*
-rwxr-xr-x  1 glpunzi users  1228876 2010-06-28 09:44 libQtNetwork.so.4*
-rwxr-xr-x  1 glpunzi users  2386004 2010-06-28 09:44 libQtScript.so.4*
-rwxr-xr-x  1 glpunzi users   261704 2010-06-28 09:44 libQtSql.so.4*
-rwxr-xr-x  1 glpunzi users   356132 2010-06-28 09:44 libQtSvg.so.4*
-rwxr-xr-x  1 glpunzi users 16761004 2010-06-28 09:44 libQtWebKit.so.4*
-rwxr-xr-x  1 glpunzi users  4300040 2010-06-28 09:44 libQtXmlPatterns.so.4*
-rwxr-xr-x  1 glpunzi users  3095752 2010-06-28 09:44 libVCLBasica.so.7*
-rwxr-xr-x  1 glpunzi users  1759540 2010-06-28 09:44 libVCLClientRunGui.so.7*
-rwxr-xr-x  1 glpunzi users   884959 2010-06-28 09:44 libVCLGui.so.7*
-rwxr-xr-x  1 glpunzi users  4311053 2010-06-28 09:44 libVCLGuiMap.so.7*
drwxr-xr-x  4 glpunzi users     4096 2010-06-28 09:44 plugins/
-rwxr-xr-x  1 glpunzi users   194890 2010-06-28 09:44 vClient*
-rwxr-xr-x  1 glpunzi users     1161 2010-06-28 09:44 vClient.sh*


([N1] glpunzi.lordzealon) #4

Ayer le envié el vClient a un amigo para que lo probara en su Ubuntu 32b, y me comenta que con "./vClient.sh" le arrancó sin problemas.

Será un problema con Linux 64b? O es problema de mi distribución? Alguien lo ha probado en Linux 64b?


(Chema) #5

Tienes que instalar las librerías de 32 bits. Para Ubuntu dicen como instalarlo aquí http://ubuntuforums.org/archive/index.php/t-65635.html

 

Saludos






([N1] glpunzi.lordzealon) #6

Si, me dá que va a ser eso, estoy en ello.

Leyendo sobre este tema, he visto que puede ser el causante que otras aplicaciones precisamente no me funcionaran por esa misma razón, pero no me había puesto a investigar.

Ya os cuento, gracias.


([N1] glpunzi.lordzealon) #7

Efectivamente...

Instalé las librerías para 32bits de Slackware64 siguiendo la siguiente guía: http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib

Y ahora vDevelop arranca..

Gracias.