Velneo vTools


([N1] OscarBarea) #1

Hola,
He heredado vTools y todo me funciona bien excepto Combinar, Rebuscar y filtrar. En todas estas opciones no me aparece nada, el formulario se presenta sin contenidos.
Alguien sabe a que es debido?
Lo he estado mirando en la documentación, y no indica que haya que hacer nada especial.
Oscar B.


([N4] Infortic) #2

No lo he heredado ni probado todavía, pero lo primero a revisar sería:

Combinar:

Combina la lista actual con alguna lista abierta de la misma tabla.
Si no hay ninguna vista de datos de esa tabla aparte de la actual, saldría vacío.

Rebuscar:

Lanza una búsqueda de la misma tabla que la vista actual, que no tenga el flag privado.
Si no hay búsquedas de esa tabla -> Saldría vacío
Si las búsquedas que hay son privadas -> Saldría vacío

Filtrar:

Te permite filtrar por los campos que la tabla actual que no sean privados.
Si los campos son privados, saldría vacío.

También prueba esas opciones en los distintos tipos de ejecución (SDI, MDI, PESTAÑA) no sé si sólo funcionan en algunos modos.


([N1] OscarBarea) #3

Gracias, había probado estas opciones, pero siempre me salen los formularios vacíos.
Entiendo que debería buscar en alguna tabla, para poder recoger los campos de las propias tablas, no?
Oscar B.


([N4] jmgonzalez.velneo) #4

Buenas

Efectivamente no hay que hacer nada especial. Si tienes alguna incidencia puedes abrir un soporte donde te atenderemos encantados. Recuerda que vTools es una open app oficial y por tanto tiene servicio de soporte para los suscriptores.

Saludos


([N3] gus.camarena) #5

Hola

También tuve problemas con una aplicación en la que utilizo tanto vTools ver 1.0.1 como vSendMail ver 1.2 (que antes heredaba de vTools y ahora de vUtiles).
Estando debidamente declaradas las herencias desde las nuevas versiones así como las instancias correspondientes y ya verificado tanto en vAdmin como en vDevelop que apuntaran correctamente tuve los siguientes problemas:

  1. Al pretender ‘Exportar a Excel’ no abría el Excel, las opciones ‘Exportar a CSV’ y ‘Exportar a HTML’ funcionan correctamente.
  2. La función Rebuscar no abría el cuadro de diálogo ‘Selección de búsqueda’.
  3. Para la función Filtrar, independientemente del campo seleccionado las opciones donde se selecciona la Condición me aparecian vacías.

La solución fue muy sencilla pero me tomó tiempo, por cierto, agradezco el apoyo de Rafael en soporte que me asistió para resolverlo.

El problema estaba en la caché local de vClient.
En Windows son dos carpetas y las encuentras en:
C:/Users/NOMBRE_USUARIO/Velneo/cacherun o C:/Documents and Settings/NOMBRE_USUARIO/Velneo/cacherun
C:/Users/NOMBRE_USUARIO/Velneo/scripts o C:/Documents and Settings/NOMBRE_USUARIO/Velneo/scripts

De cada una de ellas borra la carpeta que corresponda al servidor donde tienes alojada tu solución.
Hecho lo anterior se resolvió mi problema.

Saludos
Gustavo