Vclient ubuntu 11.04 se cierra


([N1] Vurtne) #1

Tengo varias aplicaciones que funcionan bajo windows sin problemas, pero probando con linux me di cuenta que el vclient las abre y carga pero cuando tiene que mostrar el menu se cierra el vclient inmeditamente.
El paquete tar.gz hay que instalarlo o basta con ejecutar el scrip desde una terminal descomprimiendolo?
a que se puede deber el problema?
Un saludo y gracias.


([N1] Giuseppe::Komenco) #2

Debes descomprimirlo, y arrancarlo desde el script .sh

Lánzalo desde consola para ver qué error te dá exactamente.


([N1] Vurtne) #3

Gracias por contestar. Lo descomprimo y lo arranco correctamente tal y como dices.
Y efectivamente también he probado a lanzarlo desde la terminal, el caso es que una vez termina de cargar el programa y empieza a mostrarlo en pantalla, la ventana parpadea y automaticamente se cierra, cerrándose también la terminal por lo que no puedo ver si muestra algún error o no.
Supongo que es algún fallo mio, que sería lo normal, el caso es que no consigo averiguar que es, tampoco he probado con otro equipo que use linux, pero ahora mismo no me es posible probarlo, si se os ocurre alguna cosa más toda ayuda es bienvenida.
Un saludo y gracias por vuestros comentarios / ayudas.








([N1] Giuseppe::Komenco) #4

¿...?

No se puede cerrar también el terminal...

Abre el menú principal de Ubuntu, y supongo que en Accesorios, o en Sistema (no sé donde lo colocará Ubuntu), estará el terminal. Una vez abierto, te diriges a la carpeta donde has descomprimido Velneo, en mi caso, por ejemplo, "cd /home/giuseppe/Velneo/VelneoV7-vDevelop" y una vez dentro de esa carpeta, haces "./vDevelop.sh" y nos pegas la salida.

A mi me pasó hace poco algo parecido si no recuerdo mal, y el problema se solucionó ejecutando el proyecto desde KDE. Tienes KDE instalado para poder probar?

Un saludo.


([N1] ppcamp) #5

Lo estas ejecutando como administrador?
A mí me pasaba lo mismo con el Linux mint 11.
Si lo abres desde consola hazlo con 'sudo'.
Un saludo


([N1] Giuseppe::Komenco) #6

En Linux, root debe ejecutar sólo lo que debe ejecutar, tareas administrativas. Que funcione bajo root, no es una solución


([N1] ppcamp) #7

Pues entonces yo tengo el mismo problema ;-)


([N1] Giuseppe::Komenco) #8

Como he especificado antes, lanza la aplicación desde un shell, y pega la salida una vez dá el error.

Como comento, a mi hace poco me pasó algo parecido, y lo solucioné ejecutándolo directamente desde KDE, y como me gusta más KDE, no me preocupé en buscarle la solución bajo Gnome. Si tienes KDE instalado, ¿podrías probarlo y contarnos?


([N1] ppcamp) #9

Tengo Gnome y esta es la salida del shell:

(<unknown>:7623): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
``` K ```
G_IS_OBJECT (object)' failed

** (<unknown>:7623): CRITICAL **: murrine_style_draw_render_icon: assertion
``` s ```
pixbuf != NULL' failed

(<unknown>:7623): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion
``` K ```
GDK_IS_PIXBUF (pixbuf)' failed
Violación de segmento

Probaré a instalarme el KDE, que también me gusta más...


([N1] Giuseppe::Komenco) #10

No lo recuerdo, pero juraría que era el mismo error.

Como he comentado, la solución la desconozco, no me calenté la cabeza, puesto instalé KDE, y todo bien, ahora, envía un soporte para que no crean que soy el único loco al que no le funcionaba :P

Un saludo.


([N1] ppcamp) #11

Efectivamente, instalando KDE funciona correctamente.

¡Gracias!


([N1] Giuseppe::Komenco) #12

Podrías contarnos qué distribución es en la que te encuentras?


([N1] B-Soft-2) #13

Llego tarde, pero el error que describís aparenta ser el tema utilizado en GNOME.
.
¿Tenés un tema distinto al que viene por defecto en Ubuntu?.
.
A mí con Ambiance me funciona bien. (Por las dudas, se cambia en "Preferencias" -> "Apariencia" y buscar el tema "Ambiance")
.
Saludos


([N1] Darío) #14

Tengo Ubuntu 11.04 64 bits con GNome y desde hace algunas versiones tengo este problema. Antes, ejecutando el archivo .sh con sudo me funcionaba. Ahora ya ni eso.

Lo único que me funciona es la solución planteada por B-Soft, cambiando la apariencia, pero en mi caso, en lugar de funcionar con "Ambiance", me funciona con "Clearlooks"