Valores raros en campo numérico


([N3] blanyi) #1

Buenos días.

Nuevamente por aquí con una inquietud.

Mi cliente me pidió que revisara unos registros porque mostraban unos valores que no correspondian. Revise y encontré varios registros con un campo numérico con valores bien extraños. Me llamó la atención que todos los registros con error tenían un valor de 16 millones y algo más.

El campo esta definido como numérico de longitud 4 con 0 decimales y signo falso. Se rellena con una la formula (#TASA*SALDO_CAPITAL).

Alguien sabe porque se presente este y error y como se soluciona?.

Gracias.


([N4] gontorre) #2

Buenas tardes

A mi me ha pasado con campos definidos sin signo. El problema es que si se graba un valor negativo, Velneo no lo puede grabar en el campo sin signo y el valor se desborda por arriba. Es como si empezara desde al valor máximo del campo hacia abajo. Revisa que la fórmula no pueda dar un valor negativo nunca o define el campo para que acepte valores con signo. así puedes detectar más facilmente si hay algún problema.

No sé si me habré explicado.

Un saludo


([N3] blanyi) #3

Gracias Gonzalo por tu oportuna respuesta.

Revisaré, pero en teoría la formula utilizada para alimentar el campo no tiene por donde dar negativo, pero con lo que me comentas tengo un poco más claro el asunto, ya logro entender el comportamiento, saber de donde o porque se genera un valor extraño me ayuda mucho.

Puedo estar equivocado, pero creo que eso no esta claro en la documentación de Velneo y se estoy en lo cierto es algo que deberían aclarar.

Feliz día y que Dios te bendiga.

YIMY MORA ACONCHA