Usuario para acceso a vServer en la nube


([N4] rodolformg) #1

Hola, a todos.

Después de restaurar mi servidor en la nube, instalé la nueva plantilla vBase, la ejecuté con el vClient y agregué una entidad para verificar que todo funcionara bien. 

Posteriormente intenté instalar vGestión en la misma carpeta que había creado para vBase en la intención de tener todos los datos en la misma carpeta, sin embargo la instalación de vGestión mostró algunos mensaje indicando que había encontrado ya instancias de vBase (De cada uno de los proyectos de vBAse) por lo que decidí restaurar mi servidor (Dejarlo como nuevo) y proceder a instalar cada plantilla en una carpeta diferente.

<span style="font-size: 10px;">La instalación de las plantillas en carpetas diferentes terminó bien en los tres casos, sin embargo al entrar a la aplicación vBase aún veo la entidad creada antes de restaurar el vServer. Lo más extraño es que después de cerrar el vAdmin y el vClient e intentar nuevamente abrir cualquiera de las tres aplicaciones, me indica que el usuario no es correcto, ¡Aun cuando recién acabo de utilizar este nombre de usuario y password! Voy al panel de control, reinicio el vServer para descartar algún problema ahí, intento nuevamente y tengo el mismo mensaje de que los datos de acceso no son incorrectos. 

Después de estos intentos viene a mi memoria que alguna vez me comentaron aquí en el foro que es posible utilizar el servidor en la nube con el usuario velneo (Sin contraseña), lo intentó y el vClient finalmente me permite conectarme al servidor, pero no veo ninguna instancia, luego entonces intento utilizar el usuario velneo conectándome con el vAdmin y al abrir la aplicación veo que no aparece ninguna Solución, el servidor está como si lo hubiera restaurado.

Muy, muy extraño. No tengo ningún problema en instalar las plantillas nuevamente, pero lo comento acá en el foro por si resulta útil.

 

Saludos,

 

 

 

 

<span style="font-size: 10px;">


([N1] Nacho) #2

Te explico algunos de los puntos que comentas:

- Instalar vGestion donde vBase: Al instalar la vGestión, esta contiene la vBase por lo que al crear una instancia en un directorio, instancia tanto los proyectos de vGestión como los de vBase. Por lo tanto es normal que te dige que ya existe instancia de vBase. Si quieres usar el mismo directorio (que no conlleva ningún problema), solo tienes que borrar las instancias de vBase, antes de instanciar vGestión (Esto no borra los datos!!!!)

- Aún veo los datos. Al instanciar de nuevo vBase sobre la carpeta anterior, es normal que aún veas los datos por lo que te comentaba antes.

- Usuario no es correcto: El que te diga que el usuario no es correcto, probablemente es debido a que el usuario no tiene en su grupo asignada la aplicación. No hace falta estar reiniciando continuamente se servidor para ver si se solucionan los problemas. Abre el vAdmin y comprueba como está la configuración:

- Usuario a que grupos pertenece

- Grupos: Que soluciones tiene con que permisos (esto es para el vDevelop). Que Ins. Aplicaciones tiene asignadas (esto son las instancias que puede abrir desde el vClient)

 

Espero que te aclare algo la explicación. Un saludo

Nacho


([N4] rodolformg) #3

Hola, Nacho.

<span style="font-size: 10px;">Gracias por responder. El caso es que no acabo de entender como instanciar las plantillas.

Voy a mi servidor en la nube, instalo las tres plantillas y hasta ahí todo bien.

Comienzo instanciando vConta pensando que esta instanciará vBase y Gestion, sin embargo sólo instancia vBase, así que intento instanciar vGestión pero al hacerlo me indica que ya existen instancias de Usuarios, Localizaciones y Usuarios (Después de tu explicación entiendo que esto es normal), sin embargo después de mostrar los mensajes veo que no sólo no ha instanciado vgestión sino que el servidor se detiene, cualquier acción que hago en vAdmin (Que lo tengo abierto todo el tiempo) termina con un mensaje en la barra de estado indicando que no se puede conectar con el servidor, voy al panel de control y veo que el servidor se ha detenido.

No logro salir de este círculo, sólo quiero saber como puedo lograr instanciar las tres plantillas: vBase, vGestión y vConta.

<span style="font-size: 10px;">Agradezco tu ayuda,

Saludos,

 

Rodolfo


([N1] Nacho) #4

Hola Rodolfo:

Vamos por partes:

La vConta está integrada con vBase, y la vGestión también, pero ellas no están integradas entre ellas. Si algún día se integran, será la vGestión la que herede la vConta y no al revés.

Como supongo que quieres instanciar todas en el mismo directorio, debes hacerlo un poco manual.

Primero instancias una completa, pero la segunda tienes que hacerlo proyecto por proyecto, empezando por los demás abajo.

 

Un Supuesto:

- Instanciamos vGestión

- Ahora vamos a instanciar vConta, proyecto por proyecto:

--- Instanciamos primero los proyectos de datos:

-------- Instanciamos "vConta Maestros", nos pedirá si creamos una instancia de "Entidades", pero debemos escoger la instancia que ya existe. Así ya utilizará los mismos datos que la vGestion

-------- Instanciamos "vConta RC". La asociamos con la instancia creada de "vConta Maestros"

--- Ahora instanciamos el proyecto de aplicación "vConta RC"

 

y ya está.

 

En cuanto al problema que dices del servidor, hoy yo también he tenido algún problema con la nube, quizás será un problema de los servidores.

Nacho