Toolbar en Bloc de formularios


([N1] mcp) #1

Hola,tengo en un multivista, como tercer objeto, un bloc de formularios al que le asigno en sus propiedades una toolbar. Cuando ejecuto la aplicación, no aparece.

He probado de todo y buscado en el foro alguna incidencia similar, pero no he encontrado nada. En la documentación del objeto dice que se le puede asignar una barra. Es posible? Está pendiente de implementar? 

Gracias a todos

MCP

EDITO:

en este enlace http://6x.velneo.es/1164/roadmap-velneo-v7/, se comenta que el bloc de formulario incluye una toolbar con botones de navegación a primer registro, último, siguiente y anterior con la posibilidad de añadir acciones personalizadas a dicha toolbar.

Alguien sabe como hacerlo?

Gracias

 

 

 

 

 

 

 


([N1] mvilalta) #2

Mira si esto te ayuda

http://velneo.es/2049/el-bloc-de-formularios/#more-2049

Saludos.


([N1] mcp) #3

Hola mivimu,

Ya me había mirado la información a la que te refieres, pero no comenta
nada del tema de asignar una barra o modificar la de defecto del bloc.
En los comentarios, por cierto del 10/08, tampoco.


([N1] JorgeVelasco) #4

Buenas.

He probado varias cosas y no consigo que me ponga la toolbar.

Pero tampoco he encontrado la incidencia en el vBugman.

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com


([N1] mcp) #5

Hola Jorge,

espero que Velneo tome nota y comente algo.
Encuentro un problema el modo de actualizar la ficha en el bloc de formularios.
Cuando haces una modificación, tienes que pasar a otra ficha para qué, o bien te pregunte si quieres actualizar,
o se actualiza directamente, según la opción de sus propiedades.
Pero si cambias algún campo, este cambio se refleja en el formulario, si en ese momento cierras la pestaña, la modificación no se realiza. Esto puede ser confuso para el usuario, ya que él si ha visto que cambiaba el campo y por lo tanto pensar que la modificación ya se ha realizado.
Creo que los blocs deberían tener las opciones de la rejilla, poder asignar formularios de alta, modificación y baja y que estos
se disparasen desde una toolbar que se le asignase.

A lo mejor la toolbar que no aparece es precisamente para esto

Saludos

 

 

 


([N1] mvilalta) #6

Me he creado un block y me muestra la toolbar (en la imagen donde está el cursor) y al cambiar de ficha si he modificado algo me pregunta si acepto los cambios

Adjunto imagenes no se si podrá resolverte algo.

[attachment=7431,724] [attachment=7431,725]








([N1] mcp) #7

Hola mivimu,

viendo tus imágenes, he creado un formulario donde le incrusto un bloc,
y efectivamente, la toolbar asignada aparece.

Si el bloc lo colocas en un objeto multivista, la toolbar no aparece, por lo que
parece que el objeto bloc tiene un comportamiento distinto según el contexto donde
se usa.
No sé si esto se puede considerar un bug, Velneo lo dirá.
Yo creo que el comportamiento debería ser el mismo.

Un saludo y gracias

MCP 





([N1] mvilalta) #8

Hola de nuevo. No quisiera ser pesado y a lo mejor no capto lo que no te sale pero he creado un multivista

te adjunto imagen que corresponde al posicionamiento en la 2ª columna del multivista concretamente en el elemento de nombre tercero y me aparecen en el block los registros de detalle y la barra (que por no crear otra es la misma del autoexec). Espero te ayude. Saludos Miguel.

[attachment=7444,726]


([N1] mcp) #9

Hola mivimu,

primero decirte que de pesado, nada de nada, que sería de este foro sin los "pesados" que se molestan en contestar a las cuestiones que se plantean.

Te adjunto una imagen, para que veas el contexto al que me refiero.En una pestaña multivista, cuando incuyes como objeto (en mi caso es el tercer objeto) un bloc, este sólo muestra su toolbar por defecto.

De nuevo, gracias por tu interés

Saludos

[attachment=7445,727]


([N1] mvilalta) #10

Tienes razón no he visto forma de poner la toolbar en el tercer objeto.

Supongo que tendras que dejar el multivista en dos columnas y que al pulsar en la 2ª te salga el block fuera del multivista.

Saludos. Migue.