Sincronizar 2 rejillas mediante objeto multivista


([N1] mauricio.gonzalez.telefonica) #1

Hola, he construido y reconstruido tres veces lo siguiente y no consigo que me funcione:
2 tabas: [u][b]Proyectos[/b][/u] tipo maestro / [u][b]Imagenes[/b][/u] tipo maestro con un enlace a la tabla proyectos.
+Creo un marco.
+Un menu para asociar al marco.
+Una busqueda asociada a la tabla [u][b]Proyectos:[/b][/u]
Componentes de la busqueda: Indice: ID, Modo: Todo el fichero.
+Un proceso para sincronizar las rejillas de proyectos e imagenes:
-Tabla asociada: [u][b]Proyectos[/b][/u]
-Origen: Ficha
-Tabla destino: Imagenes
-Destino: Lista
[b][u]Instrucciones:[/u][/b]
[u]1.Propiedades:[/u]
-Comando: Cargar plurales
-Parametro 1: IMAGENES_PROYECTOS
-Parametro 2: (no aparece nada y debería aparecer el campo de la tabla imagenes enlazado con proyectos)
[u]2.Propiedades:[/u]
-Comando: Añadir lista a la salida.
+Un objeto multivista:
-Tabla asociada: [u][b]Proyectos[/b][/u]
-Modo: MultiObjeto
-Objeto1: rejilla proyectos
-Proceso sincronizador: el proceso mencionada anteriormente
-Objeto2: rejilla imagenes
+Dos formularios para altas, bajas y modificaciones, asociados cada uno a su correpondiente rejilla.
+Un formulario de inicio asociado al marco y que contiene:
Un Control Objeto y que contiene:
-Objeto1: la busqueda mencionada
-Objeto2: el objeto multivista mencionado.


([N4] davidgu) #2

Hola mjgm
¿Que te aparece en pantalla?
¿Te arranca la aplicación y te muestra el formulario inicial?
¿Has probado a mostrar solo la rejilla de proyectos?
Peganos unas capturas para que te podamos ayudar.
Saludos


([N1] mauricio.gonzalez.telefonica) #3

Hola davidgu, el problema ya lo he resuelto, he eliminado las instancias, y he creado una nueva aplicacion, directorio nuevo, cajas nuevas y he repetido nuevamente la aplicacion desde cero y ahora funciona, respondiendo a tus preguntas, se cargaba la aplicacion y automaticamente salia el mensaje de que esta aplicacion debe cerrarse. Intente mostrar la rejilla proyectos sola y rompia tambien, pienso que podia tener un problema en el servidor y no en la realizacion de la aplicacion, de todas formas sigue sin aparecer:
Parametro 2: (no aparece nada y debería aparecer el campo de la tabla imagenes enlazado con proyectos)


([N4] rcueto.velneo) #4

Hola:

[quote]de todas formas sigue sin aparecer:
Parametro 2: (no aparece nada y debería aparecer el campo de la tabla imagenes enlazado con proyectos)
[/quote]El comando de instrucción de proceso [b]Cargar plurales[/b] tiene un único parámetro, que es el enlace plural por el que se desea realizar la carga de los históricos.

Los enlaces plurales son generados automáticamente por el sistema con cada índice del histórico cuyo primer componente sea el campo enlazado al maestro.

Si te fijas en el único parámetro de este comando de instrucción de proceso dice [b]IMAGENES_PROYECTOS[/b], [b]IMAGENES[/b] es la tabla histórica y [b]PROYECTOS[/b] el índice por el que el sistema ha creado automáticamente el plural.

Un saludo.