Servidor bloqueado


([N1] Ram) #1

Intenté eliminar una instancia en el vServer de una aplicación que tenía en edición en el vDeveloper. Ambas aplicaciones se colgaron y ahora no puedo acceder al servidor desde el vClient.

En el panel de control solo está activo el botón iniciar servidor, una vez clickado da el mensaje de que el servidor se ha iniciado correctamente, pero no se activan los botones reiniciar ni parar. Al mismo tiempo el servidor sigue inaccesible desde el vClient.

He probado el vClient contra el servidor de demos y va perfectamente.

¿Que debo hacer para reiniciar miservidor?

No hay prisa que ya veo que todos estamos a lo mismo.

Muchas gracias y un saludo.

 


([N4] rcueto.velneo) #2

Hola, Ram:

 

¿Podrías facilitarnos el número de puerto de tu Velneo vServer?

 

Gracias y un saludo.


([N1] Ram) #3

Es el 6093


([N4] fgutierrez.velneo) #4

Ya lo tienes solucionado. Te hemos tenido que borrar las instancias, pero ya está funcionando.

¿Qué caja tenías instanciada? ¿Una propia? ¿Reiniciaste alguna instancia? ¿Cambiaste alguna herencia?

Danos por favor un poco de detalle de lo que estabas realizando para poder localizar el error.

 


([N1] Ram) #5

Era la vDiary de las vApps. La tenia en edición en el vDeveloper y desde el vServer borre una de las instancias que genera su carga, que ahora no puedo precisar al haber borrado todas. No habia modificado nada en el vDeveloper simplemente borre la instancia. El vDeveloper quedó bloqueado y el vServer sin colgarse dejo de funcionar. Esto lo note al querer crear una nueva carpeta de disco para cargar una nueva instancia.

Gracias y un saludo.

 


([N4] fgutierrez.velneo) #6

Seguramente en el momento de borrar la instancia ya se dio el problema y todo lo demás funciona aunque no haya conexión.

Si se reproduce el problema, toma nota para indicarnos los pasos que da para poder reproducirlo nosotros.

La caja vDiary tiene varias cajas heredadas instanciadas. ¿Puede ser que no borraras todas y ejecutaras?


([N1] Ram) #7

No ejecuté, pero si que es verdad que no habia borrado todas las instancias antes de dar el error. Lo que si que creo haber hecho antes de borrar fue renombrar la carpeta de datos. En cualquier caso he intentado reproducir el error con la vPGC, borrando una de las 3 instancias y no ha pasado nada.

Si se repite intentaré recordar con más detalle los procesos.

Muchas gracias.


([N4] fgutierrez.velneo) #8

Creo que el problema se ha dado al cambiar el nombre de la carpeta en que estaban los datos mientras la instancia seguía ejecutándose. Compruébalo y así nos lo confirmas.

Gracias por tu colaboración.

Un saludo


([N1] Ram) #9

Confirmado. Acabo de bloquear de nuevo el servidor.

Al cambiar el nombre de la carpeta de datos, las instancias de datos no actualizan bien la ruta a la nueva carpeta y al borrar estas el servidor se cuelga.

Pero esta vez si he podido reiniciar el servidor desde el panel de control.


([N4] fgutierrez.velneo) #10

Muchas gracias, lo tendremos en cuenta para la próxima versión.

Gracias por tu colaboración.