Rompe vDevelop en formularios


([N1] Pepeto) #1

La verdad es que llevaba algun tiempo sin tener problemas, pero hoy , en menos de una hora, vDevelop me ha roto 3 veces.

Al comprobar el proyecto, veo que NO hay errores, o al menos el inspector de errores no los muestra.

Lo curioso, algun problema debe haber, es que siempre (tanto hoy como en ocasiones anteriores) rompe justo en el momento en que intento abrir el editor visual de un formulario.

Bueno, aqui lo dejo, si se puede solucionar bien, sino, pues no he dicho nada.

un saludo

Jose Luis


([N1] Velasco) #2

Buenas Jose Luis.

Has probado, sin llegar a abrirlo, a ir borrando componentes del formulario para ver donde está el error?

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com


([N1] Pepeto) #3

Lo cierto es que no, y es por una razon.

Como he dicho, no hay errores en el proyecto, o al menos no se muestran en el inspector.

Y de todas formas, no siempre rompe en el mismo formulario, un ejemplo,

- Entro en vDevelop, y al abrir un formulario de Articulos, rompre ...

- Ejecuto nuevamente vDevelop, vuelvo al formulario anterior de Articulos, y puedo abrirlo perfectamente, y cuando llevo un rato tabajando, en varios objetos diferentes, vuelvo a abrir otro formulario diferente y rompe de nuevo...

no se donde puede estar el problema, pero el caso es que siempre rompe al abrir formularios, incluso en formularios sencillos con pocos controles y sin eventos ni conexiones, en el resto de objetos no rompe, aun teniendo errores

un saludo

Jose Luis


([N1] alamillos) #4

Buenos dias Pepeto.

Estas en local? o en la nube?

un saludo

Juan Díaz


([N1] Pepeto) #5

en local


([N4] ns) #6

A mí a veces me rompe cuando pulso "Fin" para previsualizar un formulario. Y me pasa tanto corriendo VDevelop en Windows 7 32 bits como en Ubuntu 10.10 32 bits.

Pero el porque tampoco lo sé.








([N1] alamillos) #7

A mi me rompia teniendo un evento con un bucle mal hecho.

Acordaros tambien que en v6 rompe cuando las propiedades de los textos no estaban correctas, ahora se ha hecho una modificación al poder seleccionar el tipo de letra, haber si el asunto va por ahí, yo revisaria tabién todos los textos el formulario.

Saludos

Juan Díaz.

 


([N1] Paco.Velactiva) #8

A mi me rompe cuando pulso deshacer, al 30 o 90 segundos, como lo se
intento no utilizarlo nunca y no me cae el vDevelop. Si lo tengo que
utilizar lo pulso grabo y cierro el vDevelop y reinicio servicio, eso me
paso en la 7.4 en la 7.5 parece que no pase.


([N1] cristianvg2003) #9

Hola pepeto,

a mi solamente me ha pasado una vez y la razon era que tenia asociado un subindexador en un control microscroller ...

 

Saludos,


([N4] innovadb) #10

Hola Jose Luis

 

A mi me pasó lo mismo, que en distintos formularios me rompia al intentar abrirlos, pero encontré el problema y creo que no puede ser el mismo que el tuyo.

 

Teniamos proyectos editados y guardados con la 7.4.1 y yo los abria con la 7.4.0. Por eso supongo que no debe ser tu caso ya que tendrás todo en la 7.5.

 

Un abrazo


([N1] Pepeto) #11

Gracias a todos

@Innovadb, ya tengo todo en la version 7.5 y la 7.4 la he desinstalado por completo.

un saludo


([N1] agustin) #12

Vaya. Me espero entonces a la 7.6 para gastar dinero?


([N1] alamillos) #13

Buenos dias Pepeto.

He estado haciendo pruebas y cuando tengo un campo formula mal hecho en la tabla y lo pongo en el formulario, se me bloquea.

Saludos.

Juan Diaz.


([N1] Your Software Company) #14

Hola Pepeto.

Veo que eres n1m yo también lo soy. ¿Cómo puedo editar en local?

Gracias


([N1] Pepeto) #15

en mi blog tienes los datos de contacto

un saludo

Jose Luis

jose@ascsl.com

www.ascsl.com


([N1] Pepeto) #16

Aunque no estoy seguro del problema,

he visto que vDevelop, suele romper cuando entro en un proyecto y abro un formulario en primer lugar,

ya sea al entrar en un proyecto directamente, o al cambiar de un proyecto a otro,

pero cuando editor varios objetos, ya funciona correctamente todo el tiempo, hasta que vuelvo a cambiar de proyecto, que me queda la duda. De todas formas no lo hace siempre, solo 2 o 3 veces al dia como maximo.

Indicar tambien que no suelo trabajar con soluciones de 2 o 3 proyectos. La solucion sobre la que me suele romper tiene mas de 100 proyectos, pero es que soy muy burro, y hago muchas burradas.

un saludo

Jose Luis