regenerar indices todas las tablas


([N2] Ricardo) #1

al ejecutar este comando desde un proceso sin origen me da el siguiente error:

El comando de instrucción no se ejecuta en este contexto: Regenerar índices de todas las tablas

 

¿alquien sabe desde donde hay que lanzar este proceso? yo lo lanzo desde el menu principal y me da ese error.


([N4] velavisual) #2

@Ricardo

Acabo de realizar una prueba de la siguiente forma:

1.- He creado un proceso en el proyecto de datos que contiene sólamente la instrucción de regenerar índices de todas las tablas, y que me devuelva vOK.

2. He creado un segundo proceso que se ejecuta mediante una acción que es disparada en un menú. Lo he ejecutado en primer plano y en tercer plano y no me ha devuelto ningún error.

La variable vOK me retorna 0, no sé si es correcto o no, ya que en el momento de la prueba no tengo datos en la tabla.

No me aparece ningún tipo de mensajes en el servidor.

He buscado en el manuel pdf y no encuentro nada sobre regenerar indices de todas las tablas.

 

saludos

 

Antonio Vela

http://www.velavisual.com

 

 


([N2] Ricardo) #3

yo tambien probé varias formas y no conseguí que funcionara. Sólo lo conseguí con el vDataClient.

yo lo estoy probando con la 7.2 no se si en la 7.3 se puede ejecutar

 

un saludo

Ricardo


([N4] velavisual) #4

Ejecutar si se ejecuta, puesto que lo he mensajeado después.

Yo con la 7.3. actual, pero no sé si debe retornar 1 o 0 en vOK como variable de retorno.

 

 


([N2] Ricardo) #5

Yo lo probé en una tabla con datos y no regenera los indices, tube que hacerlo con el vdataclient