Problemas con vModApache


([N1] cesarevalo) #1

Buenas tardes, Velneadores.

He intentado configurar el vModApache en mi pc y no logro arrancarlo, cuando intento entrar por el explorador me manda el siguiente error.


404

Not Found

The requested URL /velneoweb/index.pro was not found on this server.

Apache/2.2.8 (Win32) PHP/5.2.6 Server at localhost Port 80


NOTA: Se necesita un videotutorial, o un manual mucho mas explicativo de como hacer las configuraciones.


([N4] velavisual) #2

@cesarvarelo

¿Has probado si cualquier página no servida por vModapache funciona correctamente?

Ojo que hay aplicaciones que también usa el puerto 80 y tal vez no tengas iniciado apache como tal. Skype suele ser uno con esta posibilidad.

En

The requested URL /velneoweb/index.pro

¿No te falta el dominio o servidor donde está alojado la página a mostrar?

Repasa los siguiente artículos por si te falta algo que no hayas visto:

Velneo vModApache V7

Nomenclatura de objetos en urls


([N1] cesarevalo) #3

Muchas gracias @velavisual. ya lo solucione, era por las barras de dirección y reinicio del apache.


([N1] cesarevalo) #4

Otras consulta…

Para abrir varias aplicaciones. via vModApache

debo especificar lo siguiente en la configuración del apache

<Location /SENDA1>
setHandler velneo
Vrl vatp://velneo:@localhost/INSTANCIA1
</Location>
<Location /SENDA2>
setHandler velneo
Vrl vatp://velneo:@localhost/INSTANCIA2
</Location>

Mi pregunta es, es posible que entren varias personas a la ves, o debo tener una licencia de usuarios ilimitados?

Es posible varias instancias para una misma APP ( Instancia por clientes diferentes)


([N4] velavisual) #5

@cesarevalo

En el artículo sobre Velneo vModApache v7

Dice:

Además Velneo vModApache V7 es multi-hilo, por lo que es posible atender a multitutd de peticiones web de forma simultánea con un solo enganche.

([N1] cesarevalo) #6

Gracias por la pronta respuesta. @velavisual.

otra duda, Necesito saber como hacer para que cuando se cierre la ventana del explorador(chromer, FF, IE) se elimine el enganche de la aplicación, debido a que cuando hago las pruebas, se registran muchos enganches, desde vWebClient y vModApache y tengo que eliminarlos uno por uno. al igual que no puedo ejecutar en el vDelop si queda engancho.


([N4] velavisual) #7

@cesarevalo

Desconozco realmente cómo impedir esa situación o si realmente debemos tenerlo muy en cuenta a la hora de las ejecuciones finales de aplicaciones. Si ejecutamos y editamos sobre el mismo vServer es cosa distinta.

Si el comportamiento de vWebclient en base a los enganches es el mismo que vClient, en el siguiente post se menciona algo al respecto cuando vClient se queda colgado y permanecen enganches activos.

http://velneo.es/foros/topic/si-vclient-se-cuelga-que-pasa/

El servidor lo expulsa automaticamente a los 5 minutos de no recibir nada de el. Aunque el usuario final no haga nada, el vClient pide al server refrescos terciarios cada 20 segs aprox por lo cual los enganches permanecen activos. Si uno deja de emitir el server espera 5 minutos pués puede ser debido a un fallo temporal de la conexion a internet del client.

([N1] cesarevalo) #8

Gracias @velevisual, por tus prontas respuestas. y tienes mucha razon, porque editar app final en ejecución.