problemas con v7 mac


([N4] soporte) #1

Buenos días.
Os comento los problemas que me he encontrado con el vAdmin y el vDevelop este fin de semana
Lo primero mi configuración de equipo. Tengo el vServer en una máquina virtual xp con el parallels 4 sobre leopard. uso Leopard para el resto de aplicaciones: vAdmin, vDevelop,etc...
Mi máquina es un macbook con un corel duo de 2ghz, con dos gigas de memoria ram. Una para la máquina virtual y otra para el mac.
>vAdmin
No me deja crear carpetas en el disco duro. Me da el siguiente error: Disk:CreateDir-ErrorNoAutorizado
El estilo Aqua, que es el que me sale por defecto, produce errores en la visuallización de campos. Por ejemplo al ver la ruta de las carpetas para crear sale muy pequeña y no se lee bien el texto
>vDevelop
Se cae al ponerle un contenido incial a cualquier tipo de campo. Obligando a ir al vAdmin a liberar la caja
Ocurre lo mismo que con el vAdmin, el estilo Aqua hace que se vean muy pequeños ciertos campos de texto
No siempre, aunque si varias veces se me ha cerrado al ponerles los nombres a los campos de un tabla estática
Os ocurre lo mismo en los ejecutables de Windows y Linux?
Un saludo.





([N4] agonzalez.velneo.com) #2

Muchas gracias por tus comentarios. Estos problemas ya los tenemos identificados en nuestra base de datos de incidencias:
Nº 971 Problema de fuentes muy pequeñas que no se leen.

Nº 1171: problema de cierre de vDevelop. Esto solo debería sucederte seleccionando un estilo distinto a Aqua y en cualquier editor de formulas, no solo en el de contenido inicial de un campo. Por favor confírmanoslo.

Con estos códigos puedes hacer referencia a las incidencias en el caso de que quieras conocer su estado en el futuro.

El error al crear carpetas compartidas puede venir de que no tengas permisos en el grupo de usuarios para acceso a la carpeta compartida.

Respecto al resto de plataformas, en principio estos errores no se reproducen aunque existe alguna incidencia con la visualización de texto en Linux 64, pero se produce con Velneo vClient y se reproduce el problema en otras aplicaciones.

Un saludo


([N4] soporte) #3

Buenas tardes

Efectivamente, el problema del cierre inesperado del vDevelop sólo me ocurre si no utilizo el estilo Aqua y pasa en cualquier campo que necesite abrir la pantalla de fórmulas

 

En cuanto a la creación de carpetas yo creo que lo tengo todo correcto, pero, a lo mejor, al crearlas en una máquina virtual me falta algo por configurar, porque en el vadmin le tengo puestos todos los permisos.

 

Otras cositas que me he encontrado y que seguro que ya tenéis controladas es que no puedo usar fórmulas de histórico y de que cuando voy a crear una actualización siempre está desactivado el botón para darlo de alta,d ebo ir a través de nuevo sub-objeto.

 

Pedonadme si repito alguna incidencia.

 

Un saludo y seguiremos probando


([N4] rcueto.velneo) #4

Hola:

 

 

 

Otras cositas que me he encontrado y que seguro que ya tenéis controladas es que no puedo usar fórmulas de histórico

 

 

 

Se trata de algo que ya hemos incluido en nuestro sistema de gestión de incidencias con el código de referencia: 198.

 

 

 

y de que cuando voy a crear una actualización siempre está desactivado

el botón para darlo de alta,d ebo ir a través de nuevo sub-objet

 

 

 

Para que se te active ese botón en la barra de sub-objetos de tabla del panel central de Velneo vDevelop V7 debes posicionarte en el campo enlazado al maestro que quieres actualizar.

 

En  lo que respecta a las carpetas, asegúrate de que el usuario con el que intentas crearlas pertenece al grupo de usuarios que tiene permisos al recurso compartido. Comprueba también que no sea un tema de permisos del S.O.

 

Muchas gracias.

 

Un saludo.


([N4] soporte) #5

Muchas gracias por la rápida respuesta

 

Un saludo.


([N4] soporte) #6

Buenos días

Os comento otro problema que ya tendréis reportado.

En el vDevelop al crear un campo con el tipo de enlace indirecto real,

indirecto virtual, singular de plural por indice e intentar poner la

resolución se cierra. Por cierto, estoy con el estilo Aqua.

También se me ha caído misteriosamente un par de veces cuando pincho en el texto formulario que sale en un marco para seleccionar que formulario quiero incluir.

Un saludo.


([N4] rcueto.velneo) #7

Hola:

 

 

 

En el vDevelop al crear un campo con el tipo de enlace indirecto real,

indirecto virtual, singular de plural por indice e intentar poner la

resolución se cierra. Por cierto, estoy con el estilo Aqua.

 

 

 

Efectivamente, es algo que ya teníamos registrado en nuestro sistema de gestión de incidencias con el código 1234.

 

En lo que se refiere a la segunda incidencia que comentas, intentaremos reproducirla.

 

Muchas gracias.

 

 


([N4] soporte) #8

Os comento lo que me ha pasado y que ya estará reportado pero que no he visto

- Al crear una rejilla con el asistente no me deja ponerle las fuentes aunque en mi caja están creadas. Asimismo desde el asistente no me deja añadir el campo nombre de una tabla estática. Una vez creada la rejilla si puedo ponérselo.

-Una curiosidad. Porqué si un botón mide 70x30 tiene las esquinas redondeadas y en cuanto pasa a 70x40 se queda con las esquinas sin redondear? Os adjunto imagen

 

[attachment=2103,212]


([N4] rcueto.velneo) #9

Hola:

 

 

 

 

 

 

 

Al crear una rejilla con el asistente no me deja ponerle las fuentes aunque en mi caja están creadas. Asimismo desde el asistente no me deja añadir el campo nombre de una tabla estática. Una vez creada la rejilla si puedo ponérselo.

 

 

 

 

 

 

 

El uso de las fuentes declaradas en una caja aún no es funcional.

En lo que se refiere a la creación de columnas y campos de tabla estática, te confirmamos que hemos podido reproducir la incidencia y que la hemos incluido en nuestro sistema de gestión de incidencias con el código de referencia: 1286. Con este código puedes hacer referencia a la incidencia en el caso de que quieras conocer su estado en el futuro.

 

 

 

 

 

 

 

Una curiosidad. Porqué si un botón mide 70x30 tiene las esquinas redondeadas y en cuanto pasa a 70x40 se queda con las esquinas sin redondear? Os adjunto imagen

 

 

 

 

 

 

 

Los botones toman el diseño del estilo aplicado, si cambia la forma al cambiar el tamaño del mismo, posiblemente sea debido al propio estilo. No obstante, probaremos nosotros este comportamiento en Mac.

Queremos agradecer de nuevo tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.

Un saludo.


([N4] soporte) #10

Muchas gracias a vosotros


([N4] jarboleya1) #11

Buenos días, 

 

Respecto al cambio de botón con esquinas redondas a rectangular se produce de forma automática, creo recordar a partir de que el botón supera los 36 pixels de alto. Esto lo hace automáticamente el control de Qt ya que lo comprobé en su editor de formularios. No es un efecto derivado de un bug sino que por algún motivo Qt lo hace así. A partir de comprobar este funcionamiento me he fijado y no he visto en Apple ningún botón estilo Aqua que tenga más altura que la comentada por lo que entiendo que es el funcionamiento normal. En cualquier caso de no ser la funcionalidad habitual en el estilo Aqua debería comentarse con Qt.

 

Saludos.


([N4] soporte) #12

Buenos días.

 

Perdonar si ya lo ha comentado alguien con anterioridad pero me he encontrado lo siguiente:

1.-En los tubos de ficha y de lista no se puede poner la resolución de campos en destino. Tira el vDevelop.

2.-Al hacer una búsqueda y poner un índice en los modos "Parte izquierda clave" o "Entre límites", al querer poner el límite inicial y/o final tira el vDevelop

3.- En los informes no consigo ponerle un objeto tipo campo. No se puede?. No se pueden condicionar la visibilidad de los objetos?





([N4] fgutierrez.velneo) #13

Contestado en http://v7.velneo.es/foros/topic/v7-mac-ii?replies=2#post-2485

 

Un saludo.