problema rutas con mac


([N3] Servinfor) #1

Hola he creado un evento en un formulario que al pulsarlo me genera una carpeta en el directorio del servidor, en Windows la genera perfectamente pero desde un mac no lo hace
he puesto :

crear directorio ("\\servermac\SERVIDOR\3D\Trabajos\" + #ID + " " + #CLIENTE.ABREVIATURA)


([N4] eic) #2

Hola.

¿Probaste a usar / en vez de ?

Y acuérdate de que no debes “duplicar” la barra /, salvo en el caso de doble barra, luego supongo que tendrías que indicar:

crear directorio ("///servermac/SERVIDOR/3D/Trabajos/" + #ID + " " + #CLIENTE.ABREVIATURA)

No tengo un Mac y no puedo probarlo…

Otra cosa: quizá sea interesante no poner espacios en el nombre de la carpeta.


([N3] krear) #3

Hola @serverinfor

Creo que le problema está en la ruta, dado que en mac no es la misma senda para las unidades de red.

Por ejemplo, yo tengo un ordenador con windows (ORDWIN) que comparte un disco (K) y dentro una carpeta “datos”.

Si accedo desde el explorador de archivos desde un windows la ruta sería
\ORDWIN\k\datos

Si accedo desde el mac la ruta sería
/Volumes/K/datos/

Eso sí antes de poder usar esta ruta tendría que tener conectado el volumen K, es decir haber entrado mediante red a este recurso compartido o tener configurado que se conecte automáticamente al iniciar el ordendador.

Es lo único en que puedo ayudarte!

Saludos!

Pablo


([N3] Servinfor) #4

ok Muchas gracias


([N3] Servinfor) #5

Todavía no lo crea desde un Windows
con
“//servermac/NUEVO SERVER/Velneo/pruebal” si que me la crea sin problemas

pero desde un MAC no lo hace

he probado también con
“/servermac/NUEVO SERVER/Velneo/pruebal” y tampoco


([N3] Servinfor) #6

ya esta claro era con lo de volumes muchas gracias Krear