Posible bug vClient pre-visualizando informes


([N4] Fran) #1

Buenos dias:

Jugando un poco con las nueva posibilidades de los informes (una pasada, por cierto), creo que he encontrado un bug. Me explico:

- Abro el ejemplo de vFacturación de vuestro vServer de demo.
- Voy al panel de facturación.
- Pincho la lista de últimas facturas generadas.
- Navego al histórico de líneas de facturas y elijo como salida el informe. (ta muy bien esto ;-) )
- Si cierro la ventana de previsualización del informe pulsando Ctrl+F4, se presenta el mensaje de error que envío en la imagen Error1.jpg.

Esta primera prueba la he podido reproducir en un equipo con W2000 profesional SP4, pero no sucede en otro equipo con Windows Vista.

- A partir de ahí, si vuelvo a obtener el informe y cierro la ventana con el ratón, a veces rompe vClient y otras veces no.
- Una vez en la presentación preliminar, hago Lista->Filtrar por CANTIDAD > 10, el informe se filtra correctamente y muestra menos contenido. Una vez que está filtrado, si cierro la ventana de previsualización con el ratón, vClient rompe, tal como muestro en el screenshot Error2.jpg.

Esta última circustancia la he podido reproducir en un equipo con W2000 profesional SP4 y otro con Windows Vista.

En el equipo con Windows 2000, vClient se cierra sin más. En Vista, se presenta una pantalla con la descripción del error que os adjunto en los jpg Vista1 y Vista2.

Un saludo,

Fran.

[attachment=617,71] [attachment=617,72] [attachment=617,73] [attachment=617,74]


([N4] fgutierrez.velneo) #2

Tomamos nota Fran y vamos a ver si lo podemos reproducir.
Muchas gracias por tu colaboración.


([N4] rcueto.velneo) #3

Hola:

Hemos detectado un error en las librerías de QT, que nos ha confirmado el fabricante, cuando existe más de una previsualización de informe abierta, que es el que explica la mayor parte de los errores que tienes; no obstante, el error de Windows 2000 no sabemos si está motivado por la misma causa.

¿Podrías probarlo sin tener dos vistas preliminares abiertas al mismo tiempo?

Gracias de antemano por tu colaboración.

Un saludo.


([N4] Fran) #4

Hola Rafa:

Lo he vuelto a probar cerrando todos las ventanas (el panel de facturación, la ayuda, etc) y dejando sólo la previsualización del informe... sucede lo mismo.

Si cierro la ventana con el ratón, no hay problema. Si la cierro pulsando Ctrl+F4 se presenta el mensaje de error adjuntado al post anterior.

Para descartar que fuese cosa de mi equipo, lo he probado con otro equipo con W2000 que tengo en la oficina, y sucede lo mismo.

Me he fijado que el mensaje de error hace referencia al fichero pdfddui.esp. En estos equipos tengo instaladas varias impresoras virtuales de pdf: Acrobat, bullzip, ghostview, etc. Lo mismo es alguna colisión con algún fichero utilizado por estas impresoras virtuales (que no las tengo instaladas en el equipo con Windows Vista, ya que no lo uso).

Intentaré repetir la prueba durante el fin de semana con el portátil, que tienes Windows XP, y ya os cuento el resultado.

Un saludo,

Fran.


([N4] rcueto.velneo) #5

Hola, Fran:

Antes de nada quiero darte las gracias tanto a ti como al resto de los usuarios de este blog por vuestra colaboración en la mejora de la herramienta.

En lo que respecta al problema comentado, no creemos que pueda ser un conflicto con las impresoras pdf ya que a nosotros no nos pasa –no obstante, si haces las pruebas que comentas te lo agradeceremos- sino que más bien sucede por algún problema con Windows 2000, como ya ha sucedido en otro hilo abierto anterior por otro usuario (problemas con Webkit y Windows 2000).

Muchas gracias nuevamente y un saludo.


([N4] Fran) #6

Buenas tardes:

He repetido las mismas pruebas que menciono al principio de este hilo en mi portátil con Windows XP: Ambos comportamientos se han repetido, tanto el mensaje de error al cerrar con CTRL+F4 (no se si tendrá que ver con alguna incompatibilidad con otro software instalado en mis equipos¿¿??) y la ruptura de vClient si hay más de una previsualización abierta (con una sola no sucede).

Un saludo,

Fran.


([N4] fgutierrez.velneo) #7

Como te hemos comentado, somos capaces de reproducir el problema que tienes cuando hay más de una previsualización, pero el otro no somos capaces de reproducirlo.
Si puedes identificar si las librerías que muestran el error están asociadas a algún producto concreto que podamos instalar en nuestro laboratorio para reproducirlo, te lo agradeceríamos.


([N4] fgutierrez.velneo) #8

Hola Fran:
Hemos comprobado que la presentación preliminar depende directamente de las impresoras instaladas en el sistema. ¿Puedes revisar si en los equipos que te falla la presentación preliminar tienes instaladas las mismas impresoras?
¿Qué impresoras tienes por defecto en ambos sistemas?
¿Puedes probar a cambiar de impresora por defecto?
Puedes instalar cualquier impresora estándar que te venga en el sistema operativo.


([N4] fgutierrez.velneo) #9

¿Has podido probar lo que te comentamos en el post anterior?
Gracias y un saludo.
P.D. No es por meterte prisa, es porque el post iba quedando hacia abajo e iba a acabar pasando a la otra página y a podías no verlo. ;-)


([N4] Fran) #10

Buenos dias Tito:

Perdona el retraso... llevo unos días de marrón en marrón. Efectivamente, parte de las impresoras son comunes. La impresora por defecto en varios equipos es Acrobat PDFWriter 5.0 (En Windows2000 SP4... ya se que es antiguo, pero funciona bien y es estable!!! ;-) ).

Efectivamente también, al cambiar la impresora por defecto a otra, ya no se presenta dicho mensaje de error. He probado con impresoras láser físicas (no virtuales) y con otras impresoras PDF (como bullzip, p.ej.) y tampoco sucede.

Por lo que parece solamente sucede con Acrobat Reader 5.0... lo que ya no se es si será por el propio Acrobat o por la combinación de Acrobat + otra cosa. No dispongo de ningún equipo que sólo tenga Acrobat instalado, ya que uso diversas impresoras para diversas tareas en según que clientes y las tengo instaladas todas en mis equipos para las pruebas en mi oficina.

Un saludo,


([N4] fgutierrez.velneo) #11

La cuestión es que hemos visto que el problema está en una impresora en concreto. Puede ser que, simplemente, no permita la presentación preliminar, ya que se trata de un driver de impresora virtual para generar pdf. O que haya algún conflicto con las librerías de la impresora. Pero entonces el problema no está en la presentación preliminar en sí, ya que en general funciona con todas las impresoras.

De todos modos es interesante para tenerlo en cuenta.

Muchísimas gracias por tu colaboración.

Un saludo.


([N4] Fran) #12

De nada. ;-)