Posible bug rejillas-objeto texto


([N4] Fran) #1

Buenas tardes:

Estoy haciendo algunas pruebecillas y he creado una tabla con un campo objeto texto, un formulario para editar y una rejilla con 3 columnas que tienen todas las propiedades, S.E.U.O., iguales.

El problema está en que el color del texto, en la columna del objeto texto, no cambia a blanco al mover el cursor sobre los registros de la rejilla. En el resto de las columnas si lo hace. El resultado es que el texto del objeto texto no se ve (porque es negro sobre azul oscuro), cuando el cursor está sobre el registro, y el resto de los campos si.

Adjunto JPGs aclarativos.

Aprovecho para preguntar: He puesto un control [b]Caja de Texto [/b]para editar el objeto texto, ya que con el edit normal no he podido hacer saltos de línea en el texto.
Con el control caja de texto, si es posible pero... ¿cómo saco el foco del control caja de texto [b]con el teclado[/b]?. Si pulso tab o ctrl+tab, se incluye en tabulador en el texto y pulso Intro, un salto de línea.
No es operativo tener que utilizar el ratón para poder cambiar de campo.

Un saludo,

Fran.

[attachment=1388,134] [attachment=1388,135]


([N4] rcueto.velneo) #2

Hola, Fran:

En lo que se refiere a la visualización de un campo de tipo objeto texto en una rejilla decirte que lo hemos probado con la Open App [b]vDiary[/b], simplemente añadiendo a la rejilla llamada [b]TASKS_BASIC[/b] una columna para mostrar el campo de tipo objeto texto de la tabla asociada a la misma. El color del texto es #000000. En ejecución, el comportamiento es igual en todas las columnas. ¿Podrías decirnos qué colores estás usando en tu caso?

En lo que se refiere al avance/retroceso de foco editando el contenido de una caja de texto confirmarte que por el momento tendrás que usar el ratón para ello; que es algo que ya habíamos detectado y que está incluido en nuestro sistema de gestión de incidencias con el código de referencia: 000816.

Con estos códigos puedes hacer referencia a las incidencias en el caso de que quieras conocer su estado en el futuro.

Queremos agradecer de nuevo tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.

Un saludo.


([N4] Fran) #3

Buenos dias Rafa:

Ayer estuve reunido con un cliente por la mañana y con otro por la tarde y no pise la oficina, por lo que no he podido ponerme con esto hasta esta mañana.

Utilizo el mismo color en la rejilla. Adjunto pantallazo con las propiedades de la columna en vDevelop.

He probado desde el portátil con WindowsXP (el equipo de la prueba del jueves era W2000) y sucede lo mismos.
En mi aplicación de pruebas he puesto 2 idiomas. Para probar en una aplicación con 1 sólo idioma, para descartar esta posibilidad, he probado en la aplicación vCRM de ejemplo y sucede lo mismo.

Para descartar la posibilidad de que el problema estuviese con el estilo seleccionado, he puesto la aplicación de vCRM en estilo CDE (para probar otros estilos) y me he encontrado con otro comportamiento extraño.

Adjunto 2 JPGs para explicarlo. Cuando una rejilla tiene 1 sólo registro y se usa CDE, si no pinchamos en el registro, los textos de la cabecera se muestran normalmente. Si pulsamos en el único registro que muestra la lista, el fondo y el texto de la cabecera de las columnas se ponen en negro y no se leen los títulos de las columnas.
Un saludo,

Fran.

[attachment=1447,140] [attachment=1447,141] [attachment=1447,142]


([N4] Fran) #4

Una pregunta:

Modificando las rejillas de vCRM, he visto que en algunas de las columnas ya creadas, el Tipo de Ancho asignado es [b]Adaptado al contenido[/b]. Sin embargo, este tipo de ancho no está disponible para seleccionarlo en el árbol de propiedades, ni para modificar las columnas existentes ni al crear nuevas columnas.

¿Esto es algo que no está activado en la versión actual pero de lo que vosotros ya disponeis y que estará disponible en el futuro?... Supongo que si, pero en ese caso supondría que la versión de vDevelop con la que habeis desarrollado las aplicaciones de ejemplo no es la misma que tenemos nosotros. En ese caso puede que algunos comportamientos no sean exactamente los mismos y nos volvamos un poco locos al tratar de reproducir los bugs reportados.

Otro saludo,
Fran.


([N4] fgutierrez.velneo) #5

Prueba mejor con los estilos: Cleanlooks, Plastique, Windows o los de sistema. CDE y Motif son estilos muy básicos. De todas formas probaremos ese aspecto a ver si podemos reproducirlo.

En cuanto a adaptado al contenido, es una opción que probamos de forma interna pero que aún no está activa. Pero no te preocupes, tanto el editor como el ejecutor están preparados para soportarlo.

Cuando hablas de vCRM entendemos que te refieres a vGestion ¿no?

Vamos a ver todo ello, para ver si podemos reproducirlo.

Un saludo.


([N4] Fran) #6

Buenos dias otra vez:

El ejemplo es vComercialMK... vCRM debe ser el nombre que le puse yo a la instancia (no recuerdo exactamente como lo hice).

Otro saludo,
Bye.


([N4] rcueto.velneo) #7

Hola, Fran:

Hemos comprobado (¡Por fin!) que sucede lo que comentas cuando el campo es de tipo texto enriquecido, pero no cuando es de tipo objeto texto.

Gracias por tu colaboración.

Un saludo.


([N4] Fran) #8

Vaya, no me había fijado en ese detalle... intentaré ser más concreto la próxima vez, para no perder tanto tiempo dando vueltas.

Un saludo,
Fran.


([N4] rcueto.velneo) #9

Hola:

Te confirmamos que hemos incluido la incidencia en nuestro sistema de gestión de incidencias con el código de referencia: 001222.

Con este código puedes hacer referencia a la incidencia en el caso de que quieras conocer su estado en el futuro.

Queremos agradecer de nuevo tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.

Un saludo.