Posible bug en vDevelop


([N1] Pepeto) #1

Los ultimos dias he estado haciendo modificaciones en las tablas del proyecto principal y vDevelop me rompe con mucha frecuencia.

He detectado que siempre se produce en condiciones similares:

Condiciones en las que se produce el error:

 

Se produce sobre todo al eliminar campos enlazados a tablas maestras.

El campo ademas tiene contenido inicial, una sentencia CHOOSE( #CONDICION, $VARIABLE-GLOBAL, 0 )

Al eliminar este campo, vDevelop rompe.

 

Pero tambien he detectado, que para poder eliminarlo, primero debo borrar el contenido inicial del campo.

Despues de esto ya puedo borrar el campo y vDevelop, NO rompe.

 

un saludo

Jose

 


(JuanJex) #2

Como dato a mi me rompe varias veces, tendre mas cuidado para comunicar, bueno pero como rompe el usuario se queda enganchado, por lo que yo procedia a reiniciar mi servidor en mi nube en 7.2 nunca me dio problemas pero no se sira la version en 7.3 es ahi donde se terminaba de colgar totalmente, ahora eso me ha sucedido mas de 5 veces no saben lo incomodo que es quedarse sin conexion ahora gracias a soporte lo iniciaron, pero descubri que yo estaba procediendo mal, si te quedas enganchado, te vas al vadmin/soluciones seleecionas tu solucion y abajo te lista los pys y los q estan enganchados salen con incono de una persona clik derecho deshcer desproteccionde py y asunto arreglado.

un sld.

Juan J. Moreno


([N1] Pepeto) #3

Gracias por tu respuesta.

Mi problema no es quedarme enganchado, solo queria que Velneo tenga constancia del bug y lo solucione, porque es muy molesto perder todo el trabajo realizado cada vez que rompe, y tener que volver a comenzar de nuevo.

un saludo

José

 


([N1] mariorafaelvargas) #4

A este respecto, basado en la experiencia con V7, debo comentar lo siguiente:

Comentario 1:

Yo al principio desarrollaba, creo como todos, en un solo proyecto todos los objetos necesarios (rejillas, formularios, busquedas, procesos, etc) para las N tablas definidas en el proyecto de datos. Y confome crecia en "abundancia" de objetos se hacia mas pesado "Guardar" el proyecto... y si habia alguna "ruptura" del vDevelop perdia lo avanzado... y a renegar me daba. Bueno ... conforme crecia en abundancia de objetos, y para no perder "algo" por alguna "ruptura" hacia click en "Guardar"... pero se hacia lento, lento, lento. Todo esto por que habia desarrollado "un solo proyecto de aplicacion".

Aqui en el visor de "soluciones cargadas" solo aparecian dos proyectos el de "aplicacion" y el de "datos"

 

Comentario 2: 

Para solucionar la incomodidad antes mencionada, ahora defino una "solucion" de aplicacion por cada tabla. Esto me permite solo abir el proyecto de la solucion de una tabla correspondiente, hago las adiciones o modificaciones pertinentes y el click de "Guardar".... se guarda rapido (valga la expresion)

Aqui en el visor de "soluciones cargadas" aparece un "arbol y todas las ramas" de todas las soluciones de cada tabla.

 

Y PARA FINALIZAR

 

Con el primer paso comentado el vAdmin carga la aplicacion con muestra de la progresion porcentual. A mi parecer carga rapido.

Con el segundo paso comentado... demora bastante en cargar el sistema de soluciones.

 

Personalmente, por trabajar en la nube he optado por mi comentario 2

 

Atentamente

 

MARIO RAFAEL 


([N1] Velasco) #5

Buenas Jose Luis

He cogido un campo enlazado a maestro con un contenido inicial con un choose  según  tu ejemplo y al borrarlo no me ha pasado nada. ¿¿??

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com