Pestañas "fantasma"


([N4] ns) #1

Buenas,
tengo un formulario con un control Pestañero que a su vez tiene 5 pestañas, cada una tiene los distintos plurales de la ficha que este mostrando el formulario ( a modo de histórico).

El problema es que he eliminado una par de pestañas que no se usaban mucho y al compilar siguen estando ahí.

Incluso he creado el pestañero desde cero solo con 3 pestañas y me siguen apareciendo 5, las 3 que yo elijo y 2 "fantasma".

A alguien le ha pasado esto?

Gracias


([N2] gegeo) #2

Comprueba que has eliminado el subcontrol de las propiedades del separador de formularios.

Aunque hayas eliminado su contenido, debes eliminar el subcontrol.

A mi desde luego, no me ocurre, de momento :D

Saludos


([N4] ikonos) #3

¿no habras eliminado solo los formularios que incrustas en el tab? Selecciona el tab y mira cuantos subobjetos tienes, por que me parece que has eliminado los formularios, no los objetos en el TAB.

Un saludo


([N4] ns) #4

Buenas, he borrado los subcontroles del control pestañero, es decir , solo tengo 3 subcontroles, pero al ejecutar la aplicación se cargan 5 pestañas.

Tambien he reiniciado el servicio vatp, no hay errores en la aplicación, he incluso he eliminado los formularios que iban en esas 2 "pestañas fantasma".

Le dado vueltas y no veo explicación, es como si internamente no se hubiesen borrado.


([N2] gegeo) #5

¿Has reiniciado la instancia que lo contiene?

Saludos


([N4] ns) #6

Si la he reiniciado.
Los formularios que estan en las pestañas eran inserciones de un proyecto de aplicación superior, pero los he borrado de mi proyecto con lo que tampoco tiene sentido.

He escrito a soporte y espero su respuesta.