PDF en visor HTML


([N1] lsmsusvilla) #1

Tengo un pequeño problema que no se por donde cogerlo y a lo mejor le ha pasado a alguien mas:
Hace poco se a actualizado el SO de los ordenadores del trabajo a Windows 7 Professional, tengo una aplicacion que tiene un visor HTML en el que se pueden ver documentos pdf. En el ordenador de mi domicilio con Windows 7 Ultimate, IE 8.0 y FireFox 3.6.16, Adobe Reader 9.4.1 se ve y funciona perfectamente, pero en el del trabajo con Windows 7 Professional, misma version de IE y misma version de Adobe no se ven, da error en la carga del archivo pdf. Desde un terminal del trabajo que sirve el mismo servidor pero con el SO Windows XP se ve perfectamente. Descartamos problemas del servidor, descatamos problemas del Adobe ya que en mi casa con la misma version se ve bien, descartamos problemas con el navegador ya que si abrimos cualquier pagina en el que tenga y pdf incrustado te lo deja ver perfectamente. Alguien me puede dar una pista de que me queda por mirar. Muchas gracias


([N4] eic) #2

Hola.

Si lo que estás utilizando es un visor HTML dentro de un formulario, entonces hasta donde yo sé, utiliza un navegador WebKit interno, con su propio gestor de PDF, así que no tendrían que influir las versiones de tu navegador de Windows o de Adobe. Más parece un problema que tenga el propio WebKit con Windows 7 Prof. (¿32 o 64 bits?), y que no se produce en XP o en tu Ultimate. ¿No hay posibilidad de que tenga que ver con la ruta del PDF que quieres visualizar?

Saludos,

Fran Varona


([N1] lsmsusvilla) #3

Yo diria que no tiene que ver la ruta porque ya te digo en otro terminal con Windows XP se ver perfectamente el mismo archivo pdf y en la misma ubicacion, tambien e intentado ver un archivo pdf situado en el directorio raiz del propio terminal y tampoco. Solo se me ocurre que los terminales que fueron actualizados a Windows 7 creo que se hizo una actualizacion encima de la que ya estaba, entonces el vClient etc era el que ya estaba instalado (que funcionaba bien) pero al actualizar el SO igual hay que volver a instalar el vCliente etc.


([N1] lsmsusvilla) #4

Sigo sin dar con el problema por mas pruebas que he realizado, he reistalado el adobe reader, actualizado a la version 9.4, el vClient etc y sigue dando el mismo problema.
Entiendo que soy al unico que le pasa con Windows 7 Professional ya que con la version ultimate funciona bien y en XP igual. Y si es por el W7 Professional ¿Que puede ser? si no la solucion alguna pista para poder seguir mirando.


([N3] asesoria) #5

Intenta probar con otras maquinas que tengan W7 Profesional para determinar si es con todos, o solo es en esa maquina


([N1] lsmsusvilla) #6

Buenos dias asesoria... yo no madrugo tanto, bueno como ya comente he probado en otros ordenadores con W7 Profesional y tampoco funciona, solo funciona en un terminal que sigue teniendo el XP, y en mi casa funciona perfectamente con W7 Ultimate y las mismas versiones que en el trabajo de IE, Adobe etc. Despues de hacer unas cuantas pruebas creo que el problema va a estar en el W7 Profesional que le falta algo o no carga algun plugin etc pero a partir de hay estoy perdido no se por donde mirar.


([N1] lsmsusvilla) #7

Bueno continunado un poco con el tema despues de las vacaciones y con las pilas recargadas, retomo el tema a ver si a alguien mas le pasa o si alguien del equipo de velneo tiene alguna solucion, porque con windows7 profesional no se puede visualizar un archivo PDF incrustado en el navegador web.


([N1] Giuseppe::Komenco) #8

@Ismsusvilla

Has probado a enviar un mail a soporte?


([N1] lsmsusvilla) #9

No de momento no, lo primero queria saber si a alguien mas le esta pasando y si realmente es problema del navegador de velneo o problema mio.


([N1] Giuseppe::Komenco) #10

@ismusvilla

Pues tardarías menos si le envías uno :P