no se reinicia el servidor


([N1] mvilalta) #1

Por un problema con el vClient he reiniciado desde el panel de control el servidor, pero aunque da el mensaje de que se reinicia correctamente sigue activo sólo el botón Iniciar y no logro conectarme ni con vClient, vAdmin ni vDev.

Saludos.

[attachment=3800,398]


([N4] davidgu) #2

Hola mivimu

Hemos reiniciado tu vServer, comprueba que puedes acceder correctamente.

Saludos


([N1] mvilalta) #3

observo en el vAdmin que las soluciones están todas pero han desaparecido TODAS las instancias aunque en el menú DISCO están todos los directorios de datos ¡???¡.

saludos..





([N4] davidgu) #4

Estimado mivimu

Efectivamente, quizá tenias alguna incoherencia las instancias creadas, ¿Tenias varias instancias de datos accediendo a la misma carpeta de datos?

Con el nuevo asistente de instancias puedes crear las instancias apuntando a los mismos datos que tenias originalmente.

Saludos


([N1] mvilalta) #5

Supongo que tienes razón. Crearé nuevas instancias.

De todas formas te explico lo que ha provocado la situación:

tengo una solución con una caja de objetos con un formulario,  un diujo y una acción y sin caja de datos (para tener un acerca de...)

he hecho una nueva solución y ya funcionaba.

Decido añadir (heredar) la caja anterior en la nueva aplicación y el vDevelop no parece dar problemas.

Es a partir de entonces cuando vCliente se cuelga y aunque paro el servidor reinicio las cajs etc no se arregla el problema hasta que al final ni desde el panel puedo reiniciar el servidor.

Saludos y muchas gracias una vez mas. Miguel.


([N1] mvilalta) #6

Necesito que volvais a reiniciar mi vServer.

He vuelto a heredar la caja que comentaba y se ha ido todo al traste de nuevo.

Saludos y gracias.


([N4] davidgu) #7

Hola mivimu

Solucionado, prueba ahora.

¿Puede ser que estes haciendo una herencia recursiva entre tus proyectos?

Saludos


([N1] mvilalta) #8

no hay ninguna herencia recursiva.

tengo una solución SOL1 con una caja de objetos con un formulario,  un
dibujo y una acción y sin caja de datos.

he hecho una nueva solución SOL2 independiente de la anterior y  funcionaba correctamente.

Decido añadir (heredar) la caja anterior SOL1 en la nueva aplicación SOL2  añadiendo al menú una accion con el formulario y el dibujo de SOL1, el vDevelop no parece dar problemas, sin embargo a la hora de ejecutar no aparece la nueva acción en el menú, reinicio instancias etc, etc, pero sigue todo igual. Decido reiniciar el servidor y desde ese momento ya no hay forma de ponerlo de nuevo en marcha.

Saludos.

 


([N4] fgutierrez.velneo) #9

Hemos tenido que borrarte las instancias pero ya tienes el servidor funcionando.

Cuando modifiques la herencia de una proyecto ya instanciado, debes eliminar las intancias existentes, a continuación reiniciar el servidor (pararlo y arrancarlo de nuevo) para asegurarte de que coge bien los cambios, y volver a instanciar.

De esta forma te aseguras de que no vas a tener ningún problema.

Un saludo.


([N1] mvilalta) #10

gracias otra vez.

saludos.