No me funciona este codigo para validar campos vacios


([N1] leonardo daniel velazquez fuentes) #1

Hola encontre un codigo navegando el otro dia de como validar campos vacios, venia solo para 1 campo y funcionaba, pero cuando lo intento para mas campos si me marca el mensaje de que faltan informacion, pero se cierra la ventana aun y teniendo el
set retorno proceso = NO

aqui les dejo la imagen del codigo


([N1] leonardo daniel velazquez fuentes) #2

me lleva, otra vez para variar no subio la imagen



([N2] AyudaVelneo) #3

Hola Leonardo:

1.- En el formulario en el que quieras validar los datos, en el botón que tengas para aceptar, deberás poner en lugar del comando aceptar la instrucción “Ejecutar manejador de evento” y como manejador pones el manejador que adjuntas.

2.- En el manejador, justo en la instrucción final (que ahora pone “Libre”, pon:
Else
Interfaz: Aceptar

Con eso consigues que al pulsar el botón aceptar del formulario, se ejecute el manejador que comprueba los datos.

Si tiene algún error, no se acepta el formulario. En caso contrario se acepta el formulario con la instrucción de Interfaz.

Un saludo


([N1] leonardo daniel velazquez fuentes) #4

Hola Jose, hice lo que me dijiste y efectivamente ya no se cierra el formulario, pero me envia 2 veces el mensaje de Falta de datos



([N1] leonardo daniel velazquez fuentes) #5

SOLUCIONADO gracias de nuevo Jose Villa encontre mi error.! lo que sucedio es que tenia una “conexion de evento” de cuando hice las primeras pruebas, lo elimine y asunto arreglado…