Multivista no responde


([N1] wikiwiki) #1

Estoy utilizando un Multivista y no me funcina. No me carga los plurales.

Es más, lo pongo en vertical y me lo saca en horizontal y ayer me funcionaba. He reiniciado el Vserver y nada.

A alguien le pasa.

Un saludo.

 


([N1] wikiwiki) #2

Ahora si funciona en vertical, no sé porqué.

Pero tengo una duda. Si quiero ver dos rejillas con el multivista de dos tablas en que se relacionan por solo un campo y un solo registro, el enlace sería a maestro?

En el Multivista pongo, entrada ficha y salida lista. Y el proceso:

Cargar plurales

   Añadir lista a la salida.

 

Está bien? Por que en el multivista me saca la primera rejilla y en la segunda no sale nada, parece que no carga nada.

Que hago mal. He mirado los ejemplos y parece todo correcto.

Un saludo.


([N4] velavisual) #3

@nachocrespo.telecable

 

Comprueba que en las propiedades del proceso sincronizador del multivista tengas el origen en FICHA y el destino en LISTA.

 

saludos

Antonio Vela

http://www.velavisual.com

 


([N1] wikiwiki) #4

Así lo he puesto, Antonio,

mira:

[attachment=10160,972] [attachment=10160,973] [attachment=10160,974]


([N4] velavisual) #5

@nachocrespo.telecable

 

El multivista que yo uso, tiene entrada y salida tipo lista, ¿porqué?

 

En un formulario tengo un control objeto con dos objetos; el primer objeto es una búsqueda y el segundo objeto es el multivista, de ahí entrada y salida tipo lista para el multivista.

 

saludos

Antonio Vela

http://www.velavisual.com

 

[attachment=10161,975]


([N4] velavisual) #6

Faltaba la pantalla en ejecución:

 

[attachment=10162,976]


([N1] wikiwiki) #7

Tienes entrada ficha, salida lista en el proceso.

Y el proceso?

La diferencia que veo es que yo lo lanzo desde una acción.

 

 

 

 

 


([N4] velavisual) #8

El contenido del proceso junto a las propiedades.

 

[attachment=10164,977]


([N4] velavisual) #9

...y en verticial tambien me funciona.

[attachment=10165,978]


([N1] wikiwiki) #10

Por mas que rebusco, lo tengo igual que tú.

No veo porque no me carga los plurales.

 


([N4] velavisual) #11

Bueno, no te preocupes, mañana seguro que verás cual fué el error.

 

Mírate bien los indices, reinicia instancias o mejor reinicia el servicio.

Si dispones de vDataclient mira y comprueba los datos de las tablas....

 

saludos


([N1] wikiwiki) #12

Cree indice a maestro, y ejecuto con f5.

 


([N1] wikiwiki) #13

Sigo con el problema que no me carga en el multivista la segunda rejilla.

Tengo dos tablas una de Partes de trabajo y otra de Empresas Perica.

Añado registros diarios  indexados por fecha.

Creo el Multivista entrada ficha salida lista. Creo el proceso sincronizador con Cargar plurales y añadir lista a la salida.

Y no tira. Veis algo que yo no vea?

Estoy pensando q cuando crea la relacion me crea un indice Partes en la tabla historica. Ese indice relaciona el campo ID de las dos tablas no?

pero lo logico es que relacione los dos campos fecha que es por el campo q están relacionadas la tablas. Como haria eso?

En cada tabla hay un registro diario, quiere decir esto que no hay plurales?

Toi atascao.

Un saludo.

 

[attachment=10191,980] [attachment=10191,981]


([N1] tinlogro) #14

Quizá te pase como a mí (yo creo que lo he resulto): http://velneo.es/foros/topic/problema-multivista?replies=4#post-10249


([N1] wikiwiki) #15

No es eso Tinlogro.

Hasta el momento no he logrado saber porque es.

Aprovecho de nuevo para preguntar. Si tengo dos tablas maestras y quiero hacer un multivista con ellas como seria el proceso sincronizador?

Tienen estos campos:

ID autonumerico que no estan relacionados entre ellas. los crea velneo a su bola.  No me interesan.

Fecha: es el campo por el q me interesa hacer el multivista ya que para la primera tabla hago una busqueda por fecha.

Un saludo.


([N1] tinlogro) #16

Perdona velavisual pero, ¿cómo has enlazado la búsqueda con el multivista?. Estoy intentando que una vez tengo creado el multivista, al seleccionar un valor del mismo, me filtre los datos en la búsqueda, pero no logro hacerlo.

 

Gracias


([N4] velavisual) #17

@tinlogro

 

En la imagen -12-06-2010_23-08-24.png de uno de los mensajes anteriores, uso en un formulario un objeto control.

Dentro de este objeto tengo como objeto 1, la búsqueda (para que alimente con su resultado al multivista)

Luego como objeto 2, tengo el multivista (que según la ficha deseada por el operador de la búsqueda anterior) me busque sus clases de incidencias (proceso sincronizador de sus plurales)

 

saludos

Antonio Vela

http://www.velavisual.com