Migrar instalación de un servidor a otro


([N1] pater) #1

Hola.
Un cliente nos ha solicitado cambiar su aplicación V7 desde el servidor actual a otro. Evidentemente la idea es mantenerlo todo como está ahora: Usuarios y grupos, soluciones, licencia velneo, etc…
Sabemos donde están ubicados los datos, y creo que tengo localizados también las carpetas de la solución en SysWow64. Tenemos los instaladores ejecutables de todas las herramientas necesarias de la misma versión que tienen instalada (la 7.4, concretamente).
Deciros que su servidor no tiene licencias de edición, por lo que no podemos usar la herramienta vInstallBuilder.
¿Alguien podría orientarme describiendo una lista de pasos a llevar a cabo?
Muchas gracias por cualquier ayuda y respuesta que me podáis ofrecer.
Un saludo


([N4] eic) #2

Hola.

Sólo hay que:

  • Instalar los ejecutables (vServer, vAdmin, etc.)
  • Copiar las carpetas (todas) que cuelgan de SysWow64\etc. (ahí están los ficheros de las soluciones, los usuarios, grupos, permisos, etc.).
  • Arrancar el vServer

Y… ya está.


([N1] pater) #3

Hola. Gracias por responder tan rápido. He estado viendo la ruta que me comentas, pero no coincide con la que veo en el servidor. Es decir, no existe la carpeta etc en SysWow64. En la ruta C:\Windows\SysWOW64\config\systemprofile\Velneo tengo dos carpetas: una con el nombre de la aplicacion, y otra llamada server. ¿Te referías a esta?
Respecto a la licencia V7, entiendo que habrá que ejecutar de nuevo el vActivator en el equipo destino. Requiere de algún paso previo en la web de velneo, tipo reactivar licencia?
De nuevo muchas gracias y un saludo.


([N3] blanyi) #4

Hola Pater.

Efectivamente la ruta es C:\Windows\SysWOW64\config\systemprofile\Velneo
Debes copiar del servidor actual todo lo que está dentro de la carpeta Velneo al nuevo servidor en la misma ruta.

La instalación del vserver en la nueva máquina requiere activarla, si la licencia es express, debes solicitar a Velneo nuevamente una licencia para esa nueva máquina, pero tu debes ser nivel 2. Si la licencia es profesional o enterprise no se cual es le procedimiento por lo que te recomiendo consultes con Velneo directamente.

Cordial Saludo.

YIMY MORA ACONCHA


([N1] pater) #5

Muchas gracias por vuestra ayuda. Me queda 100% claro.
Un saludo.


([N1] pater) #6

Pues finalmente la migración se ha retrasado mucho por cosas del cliente. La estuve haciendo estos días, y ha ido todo bastante bien excepto la activación de la licencia.
Teóricamente, durante la instalación de vServer se debería ejecutar el componente vActivator, tal y como indica el siguiente post:
http://velneo.es/info_v7_716_es/velneo_vserver_v7/instalacion_y_configuracion/activacion_de_la_licencia/
Sin embargo, al hacer la instalación lo único que se me pregunta es si quiero instalar vServer como servicio. La respuesta a esto, obviamente es que sí. Estoy ejecutando un instalador antiguo, de la versión 7.7.2, ya que tengo todo el set de herramientas de esa versión.
No se me lanza en ningún momento el dichoso vActivator, y en los mensajes del vAdmin me aparece el fatídico
“Servidor vatp iniciado sin licencia”
He preguntado al soporte de velneo por esto, y me han dicho
“Velneo vActivator es un componente que debe ser ejecutado. No se ejecuta automáticamente.”
Y seguidamente me remiten al post que pego más arriba.
¿Alguien podría decirme cómo ejecutar el vActivator?


([N1] vgegeo) #7

vActivator se instala junto al vServer.

Comprueba en la carpeta donde tendras instalados los componentes, y encontraras vActivator.

Ejecutas, y completas los pasos que requiere.


([N1] pater) #8

Me respondo a mí mismo. No está del todo bien explicado en el post, en el que entendía que el vActivator se ejecutaba sólo durante la instalación de vServer. Pues bien, no es así. El vActivator es un ejecutable que veremos en la ruta donde se instala velneo en el equipo, en el subdirectorio correspondiente de Archivos de Programa. Hay que ejecutarlo manualmente y seguir los pasos descrritos en el post.
Aunque se trata de otro problema os comento, para quien le pueda resultar útil: Tras ejecutar el vActivator siguiendo las instrucciones del post, no conseguía iniciar el servicio vatp, ya que se detenía de forma automática al iniciarlo. El problema era que la licencia que activé era para el puerto 6900, en lugar del puerto por defecto que es el 690. En ese caso, hay que ir al registro de Windows, y modificar
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Vatp Service 7.7.2.10108
La propiedad ImagePath, añadiendo al final de la ruta los parámetros
/port=6900 /log
Entiendo que el no esnecesario, pero sí útil, para ver en el registro de eventos de Windows los problemas que pueda haber con esta clave.
Una vez hecho esto ya pude iniciar el servicio correctamente.


([N1] gutierrez) #9

Hola, me puedes indicar como traspasar las licencias en velneo 6x, vamos a cambiar el equipo en unos días.
Gracias


([N1] mcventur apellido) #10

Hola Gutierrez.
Si la licencia actual es del tipo VVMW01-XXXXX-XXXXX-XXXXX entonces puedes reactivar la licencia tú mismo desde el panel de usuario. Si es del otro tipo ( una serie numérica continua del tipo XXXXXXXXXXXXXX) entonces debes enviar a velneo una solicitud de reactivación indicando el motivo.
Un saludo.