Mensaje de Instruccion sin programar


([N1] Antonio Osorio) #1

Hola.

He creado un formulario en el se introducen nombre y direccion, tiene un boton aceptar y otro cancelar, tambien tiene un evento, que he asociado al boton aceptar y que se ejecuta al ganar el foco el boton, en este evento se comprueba si el campo nombre esta vacio, en cuyo caso lanzo un mensaje, activo el foco del objeto nombre, retorno el proceso a NO y finalizo el proceso.

Al hacer esto me sale el siguiente mensaje: Instruccion sin programa: Activar foco objeto ( NAME )

Que estoy haciendo mal?

Un Saludo.


([N4] fgutierrez.velneo) #2

En vBugMan tienes un ejemplo de eso mismo que estás realizando, y no aparece el mensaje.

Imaginamos que hay algo más. ¿Como lanzas el formulario? ¿Puede ser que el formulario lo lances desde otro evento?

Coméntanos qué montaje tienes para ver si podemos reproducir el problema que tienes.

 

Un saludo.

 

 


([N1] Antonio Osorio) #3

Hola.

Para lanzar el formulario he creado una accion con el comando disparar objeto y el objeto que dispara es un proceso en el que cargo una lista, selecciono la primera posicion y modifico la ficha seleccionada con el formulario al que le he creado un evento para el boton aceptar.

Un Saludo.

 


([N3] blavan) #4

He probado con un formulario y me funcioan bien, ahora voy a intentar hacer como tu lo planteas

 


([N3] blavan) #5

He repetido lo que haces y me da el mismo error, pero pregunto con que instrucción finalizas el proceso?

 


([N1] Antonio Osorio) #6

Hola.

El Evento, lo termino con un SET Retorno Proceso = NO y un Finalizar Proceso y el Proceso con un Finalizar Proceso.

Un Saludo


([N4] rcueto.velneo) #7

Hola:

El problema está en el uso del comando de interfaz en un formulario disparado desde un proceso mediante el comando de instrucción "Modificar ficha seleccionada con formulario". Es algo que tenemos registrado en nuestro sistema de gestión de incidencias con el código 1379.

Un saludo.