Marca de agua vReport


([N1] andrei) #1

Me gustaría poner una marca de agua (como imagen de fondo, OJO!) en un informe hecho en vReport, en el Detalle de la misma. Sé ponerlo en la cabecera.

Me he pasado por aquí: https://velneo.zendesk.com/entries/36025997-Informes-externos-incluir-imagen-de-fondo-en-un-informe

Pero el truco que usan es poner una imagen en la Cabecera de informe y luego hacerla pequeña.
En mi caso no me sirve porque yo ya tengo cosas en la cabecera.

¿De qué manera podría hacer?


([N3] pacosatu) #2

Hola andrei.

¿Cuál es el problema? Funciona perfectamente.

Lo de “hacer pequeña la cabecera” está mal expresado, significa que, después de insertar la marca de agua, vuelvas a poner la cabecera del tamaño que tenía inicialmente.

Saludos
Paco Satué


([N1] andrei) #3

El problema es que en ese ejemplo la Cabecera de la página únicamente tiene una imagen (la que va a ser el fondo del cuerpo, la marca de agua). Si tiene más elementos no funciona, o algo estoy haciendo mal.

Lo hago así:

Pongo la imagen en el Cabecera de página.:

Redimensiono la cabecera a mi parecer, dejando la imagen ‘escondida’:

El resultado no es el del ejemplo, como puedes comprobar:

Como se puede ver en la última imagen, mi marca de agua (la imagen que lleva escrito “COPIA”), no se ve por detrás de las líneas del documento.

¿Me equivoco en algún paso?


([N4] PedroN) #4

Hola Andrei.
Coincido con Paco. Sí funciona.
Sólo se me ocurre que tengas activado el “Alto automático” en la sección y no debe ser así.
Saludos,


([N3] pacosatu) #5

Hola andrei.

Si piensas que el error se produce por algún objeto de la cabecera, los vas quitando uno a uno hasta que funcione correctamente.

Además,

  • Procura que la marca de agua sea un PNG con transparencia
  • Haz una prueba con un Informe sencillo para comprobar que no es problema del fichero de marca de agua

En teoría, la marca de agua se pinta en primer lugar por estar en la cabecera y a continuación se pinta el detalle que quedará encima de la marca de agua.

¿Puede haber un problema con el driver de impresora láser?

Nos cuentas
Saludos
Paco Satué


([N1] andrei) #6

Buenos días por la mañana,

El problema era que tenía el alto de la cabecera automático, no había caído en eso, muchas gracias @PedroN.

Gracias a ti también por tu tiempo, @seh.