[MacOS] Lentitud vDevelop


([N1] glpunzi.lordzealon) #1

Hola a todos,

Escenario:

MacBook IC2D 2GHZ, 2GB RAM, conexión ONO 6MB, MacOS Leopard 10.5.7

 

La verdad, es que he estado probando vDevelop en la máquina de la oficina, y vá de lujo, pero, ésta, es un IC2D 2.6 con 4GB de RAM. En casa, en mi MacBook, anoche me dí cuenta, que vá bastante lento. Me explico.

Cargo la solución vTPV. Doble click en la caja de Datos, Despliego "Tablas" (1, 2 segundos en responder), doble click en Artículos (1, 2 segundos en responder, y así.

Es ésto normal? En Mac no está optimizado aún el rendimiento? O el rendimiento no está optimizado aún del todo en ninguna plataforma, pero no lo noto por la ram del ordenador de la oficina?

Un saludo.


([N1] JorgeVelasco) #2

Buenos días.

Yo tengo un macbook unibody de 2 ghz con 4 gigas de ram. Tengo la 10.5.7 de Leopard. Internet, en mi casa, con telecable de 10 megas. En mi oficina también tenemos telecable

Tengo máquina virtual de windows xp con 1,5 gigas de ram.

Teniendo la máquina virtual para hacer otras cosas y conectándome con el vDevelop de mac a mi oficina, abriendo nuestra solución que es mas grande que la vTPV no me tarda eso, lo hace como si estuviera en la propia oficina.

Un saludo.

 

 

Jorge Velasco

SISTEMA BINARIO 


([N2] overall) #3

Buenos días,

El rendimiento del vDevelop en Mac es como comenta glpunz, cada vez que le das a un objeto, sea el que sea la respuesta no es inmediata, haciéndose inviable su desarrollo. El hecho que tarde unas décimas de sugundo no es nada, pero como la espera es en cada click del ratón se hace desesperante.

Tengo un Mac con Leopard 10.5.7 y 4 mb de ram. En cambio si virtualizo Windows en el Mac me va fenomenal. O sea, que tengo un mac y solo arranco windows para desarrollar en Velneo.

Espero que dentro de poco estén resueltos todos los problemas que hay en Mac.

Saludos

Overall


([N4] jarboleya) #4

Hola a todos,

 

Yo utilizo un Macbook Pro con 2GB de RAM y Leopard 10.5.7.

 

@Overall, el código de Velneo V7 es el mismo en todas las plataformas, lo que cambian son las librerías de Qt. Las mejoras en este sentido deberán llegarnos de la mano de Trolltech.

 

Es cierto que el interfaz es más fluido en Windows que en MAC, sin embargo, la sensación de retardo que tengo en MAC no llega a 1 ó 2 segundos. Mi sensación es como la que comenta Jorge Velasco.

 

¿Os ocurre con todas las aplicaciones?

¿Os ocurre con alguna de las Velneo Open Apps?

 

Si es así, me gustaría probarlo con la misma aplicación que usáis vosotros.

 

Gracias.

 


([N1] glpunzi.lordzealon) #5

Hola jarboleya,

Pues parece que es igual en vTPV y vFacturación, ambas Open Apps.

A ver, no es que sea infumable, pero, en LInux y en Windows, si tienes el cursor posicionado en la tabla LINEAS_DE_TICKET y haces doble click en FAMILIAS, se abre la tabla y el recuadro de propiedas se actualiza practicamente al instante. Aquí, parece que hay un retardo como de, entre medio segundo y un segundo, que lo hace un poco, como diría, extraño.


([N4] jarboleya) #6

Hola glpunzi,

 

Lo pruebo con el ejemplo que comentas y te confirmo si en mi equipo se produce ese retardo de casi un segundo.

 

Gracias.








([N1] JorgeVelasco) #7

Buenas tardes.

 

Me he puesto a abrir las Open Apps instaladas en mi empresa ,en Leopard y en la máquina virtual del windows xp.

Me he puesto a abrir las tablas , a mover las ventanas y si, se nota un muy pequeño retraso o lentitud en dibujar la pantalla. Pero es casi imperceptible.

Un saludo.

 

 

Jorge Velasco

SISTEMA BINARIO


([N1] glpunzi.lordzealon) #8

HOla de nuevo.

 

jovefer, cambia el estilo a Plastique, y verás el retardo. Me acabo de dar cuenta (no recordaba haberlo cambiado). Lo he cambiado de nuevo a Aqua, y ya vá bien.

x23.txt (66.7 KB)

x23.txt (66.7 KB)

x23.txt (66.7 KB)


([N1] JorgeVelasco) #9

Uffffff

Si señor!! Ahí si que se nota la diferencia. Tarda sobre 2 seg en sacarlo.

Un saludo.

 

 

Jorge Velasco

SISTEMA BINARIO


([N4] jarboleya) #10

Buenas noches,

 

He probado lo comentado y confirmo que he podido reproducirlo con las siguientes conclusiones:

 

Tienen retardo los estilos:

- Windows

- Plastique

- Cleanlooks

 

No tienen retardo los estilos:

- Motif

- CDE

- Aqua

 

Muchas gracias a todos por vuestra colaboración. Os confirmo que ya está incluido en nuestro sistema de gestión de incidencias con el código de referencia: 1527. Con este código puedes hacer referencia a la incidencia en el caso de que quieras conocer su estado en el futuro. Queremos agradecer de nuevo tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.