Localizadores - formulario de retorno


([N4] apinna.winmotor) #1

No consigo que un localizador retorne el formulario correspondiente que tiene asociado. Por supuesto lo estoy lanzando desde un botón de "Acción" con el comando "disparar objetos" cuyo "objeto uno" es el localizador y "objeto dos" es el formulario de la ficha correspondiente, pues se presenta correctamente la rejilla asociada al localizador, localiza correctamente el registro que busque pero no retorna de ninguna forma el formulario.

Saludos y muchas gracias

 


([N1] JorgeVelasco) #2

Buenos días.

Me he creado una acción sin tabla de origen. He puesto disparar objeto un localizador y después su formulario.

La acción la disparo dentro de un menú que está en un botón de un formulario de una tabla cualquiera.

Al pulsar me muestra el localizador y me devuelve el formulario puesto correctamente.

Que es lo que estas localizando y desde donde? a ver si le vemos el porqué.

Un saludo.

 

 

Jorge Velasco Fernández

THE SEED SOFTWARE COMPANY


([N4] apinna.winmotor) #3

Pues acabo de comprobar y me parece increíble que va a ser de nuevo un problema con Vista que es el sistema que tengo en el portátil de casa. Estoy ejecutando desde la oficina el mismo mapa y si funciona correctamente el localizador, retorna el formulario.

Hasta esta tarde no lo puedo confirmar y aunque me parece poco problable estoy seguro al 99% que no le volví a tocar nada al mapa después de las pruebas del Viernes.

Muchas gracias de nuevo Jorge, te tendré informado


([N4] apinna.winmotor) #4

Mil perdones a Jorge en particular y a la comunidad en general: esto ha sido un fallo debido a un ataque de gilipollez provocado por una saturación de teclas, prometo que cuando detecté este fallo no había bebido alcohol ni fumado nada raro.

No sé si no hice bien las pruebas o simplemente no me di cuenta de que utilizando un localizador con el teclado en V7 hay que tabular antes de dar el intro a diferencia de V6 que recogía inmediatamente el intro.

En fin, que perdón por el tiempo perdido y muchas gracias por la ayuda





([N4] velavisual) #5

Los cliente no deben acostumbrarse a que las cosas no pueden cambiar. Nosotros como clientes de Velneo v7 ya lo hacemos, tabular