Lanzado qt 5.9 con soporte extendido.


([N4] mittosoftware) #1

Qt 5.9 lanzado. Entre los muchso arreglos, permite impresion desde el qtWebengine, y es de soporte extendido, igual que Qt 5.6. Si o si deberia ser la base para Velneo 22, ¿no les parece?
https://blog.qt.io/blog/2017/05/31/qt-5-9-released


([N3] pacosatu) #2

Hola cjribera.

La versión 21 ha salido con QT 5.6.2 y soporte extendido hasta 3 años.
No veo razón para que Velneo se dé prisa en actualizar a 5.9. Ójala me equivoque.

Yo espero que dediquen muchas más horas-hombre en actualizar los cada día más obsoletos Widgets desde vDevelop.
Desde hace ya algún tiempo que instalamos unas magníficas librerías de QT en nuestro ordenador y sin embargo no podemos usar gran parte de sus funcionalidades. Lo que ya digo siempre, mucho más QT/C++.

Saludos
Paco Satué


([N4] mittosoftware) #3

@Paco, solo la impresión desde el visor html ya justificaría el upgrade, sin contar todo lo nuevo que trae en cuanto a features, pero mas que todo bugfixes.

Y de lo pendiente, para mi gusto DE LEJOS, lo mas urgente es tener el manejador de registro https://soporte.velneo.es/hc/es/community/posts/222980587-Crear-un-manejador-de-registro, porque los tubos ahora solo sirven para el alta, es decir, son inútiles cuando uno quiera replicar y sincronizar a mano, donde deben sincronizarse en modificaciones (porque son registros existentes que uno modifica en momoria, y despues debe sincronizar con los reigstros en disco, cuando todo este ok). Eso sin contar el buffer que debe tener cualquier marco transaccional parent-child, para asegurarse que si el usuario pueda cancelar las modificaciones en el formulario padre, y al hacer eso, todos los plurales vuelvan a su estado original. Lograr eso ahora es demasiado tedioso, todo el life is soft se va al garete allí.