Interfaz: Aceptar


([N1] wikan) #1

Como me dijeron en su momento, [url url=topic/evento-boton-pulsado]http://v7.velneo.es/foros/topic/evento-boton-pulsado[/url]
el problema está que ahora, al intentar modificar dicha ficha, no lo realiza. Al pulsar el botón se ejecuta el evento pero la interfaz no es aceptada o lo que es lo mismo, no puedo modificar el registro.


([N4] rcueto.velneo) #2

Hola, manugc:

Decirte que el truco que te dimos en ese hilo al que haces referencia fucniona tanto en altas como en modificación. Ese mismo evento que te habíamos indicado lo he usado en un formulario de modificación obtenido desde una rejilla y funciona perfectamente.

¿El evento lo estás disparando directamente desde el botón? Es decir, que el botón tenga definido el valor [b]Ejecutar evento[/b] dentro del parámetro [b]Comando[/b].

¿De qué forma estás presentando el formulario? (Formulario de modificación de una rejilla, desde un proceso, etc.).

Gracias por tu colaboración.

Un saludo.


([N1] wikan) #3

Lo presento desde un proceso.
Es un sistema de gastos personales y entonces si es un ingreso o un gasto, lanzo un formulario u otro. Algo sencillo para probar cosas vamos.
Me lanza el evento, pero no cierra la ventana.


([N4] fgutierrez.velneo) #4

¿Nos puedes detallar un poco más? Podemos deducir que se trata de un proceso en el que presentas un formulario con Modificar ficha seleccionada con formulario. ¿Es así? ¿O usas pedir formulario?.

¿Desde dónde lanzas el proceso?

Gracias por tu colaboración.


([N1] wikan) #5

Voy a intentar explicarlo lo mejor posible.
Desde una rejilla en un formulario, mediante la conexión a evento, Itém: Doble Click lanza un evento.
Dentro de este evento compruebo un campo y luego uso, Modificar ficha seleccionada con formulario
Luego en el formulario, segui los consejos de rcueto (Siento no saberme tu nombre, disculpa), dicho evento funciona perfecto. Pero al hacer la modificación, este es lanzado pero no acepta ni cierra la ventana.


([N4] fgutierrez.velneo) #6

Es que entonces el montaje es un poco más complejo, no estás lanzando el formulario desde un proceso, si no desde un evento, es un objeto distinto. Entonces estás lanzando un evento desde otro evento. Vamos a comprobar ese caso y te comentamos.

Gracias por tu colaboración y un saludo.


([N4] rcueto.velneo) #7

Hola:

Os confirmo que, efectivamente, se produce un comportamiento extraño cuando se dan las circunstancias descritas por manugc. Así que lo hemos incluido en nuestro sistema de gestión de incidencias con el código nº 001209.

Manugc, muchas gracias de nuevo por tu colaboración.

Un saludo.


([N1] wikan) #8

De nada, por ahora entonces lo cambiaré para poder seguir trabajando con la aplicación.
Ya me darán algún regalo cuando salga la definitiva ;)
Son bromas jajaja.