Instruccion "Ejecutar Documento"


([N2] overall) #1

Buenos días,
La función "Ejecutar Documento" no funciona, no se si estoy haciendo algo mal o es un bug. Este problema ya lo mencioné el la última beta y me dijeron que lo solucionarían.
Adjunto Imagen, los documentos que se guardan se ejecutan en el mismo ordenador, o sea, en la misma ruta.
Saludos
Overall

[attachment=1638,172]


([N4] rcueto.velneo) #2

Hola:

Confirmar que el comando de instrucción [b]ejecutar documento[/b] es funcional en la versión actual. Te aconsejamos que hagas las comprobaciones siguientes:

Que el documento exista, o que la senda del mismo sea correcta, para ello puedes usar el comando de instrucción [url url=../info/v7_70_es/velneo_vdevelop/cajas_objetos_y_editores/#existe_fichero]¿Existe fichero?[/url].

Que en esa máquina el tipo de archivo que intentas ejecutar tenga asociado un programa por defecto.

Un saludo.


([N2] overall) #3

Lo miraré, gracias
OVerall


([N2] overall) #4

Lo siento, pero no hay forma de que me presente el documento. Lo he probado como has dicho rcueto, el fichero me lo encuentra pero nunca lo lanza. Lo he probado desde Windows XP con un fichero en el propio sistema operativo y también lo he probado desde Mac, con su fichero en el mismo MAc. Adjunto imágenes de vDevelop (peroceso y formulario) y de vClient.
Saludos
Overall

[attachment=1643,173] [attachment=1643,174] [attachment=1643,175]


([N4] agonzalez.velneo.com) #5

Hola [b]overall[/b]:

En primer lugar indicarte que de tus capturas se deduce que lo único que parece estar incorrecto es el comando Interfaz: Procesar control (DOCUMENTOS, Seleccionadas).

En este comando debes seleccionar, en el parámetro Fichas a procesar, el valor Todas en lugar de Seleccionadas. Este último valor solo es para trabajar con rejillas de tipo múlti-selección.

El resto del evento y código parece estar correcto, de hecho hemos reproducido tu sistema y nos funciona correctamente en Linux y Windows. Te recomendamos que pruebes con varios tipos distintos de archivos (pdf, bmp, etc.) ya que como te comenta Rafa es muy importante que el Sistema Operativo tenga asociado correctamente un programa para la apertura de ese tipo de archivo. Por lo demás el comando Ejecutar documento funciona correctamente.

Saludos.


([N2] overall) #6

Hola agonzalez, antes ya tenia la propiedad de Interfaz:Procesar control a Todas, ya lo vuelto a cambiar y nada de nada. No se donde está el problema pero tengo asociados todos los formatos (pdf, txt, doc, etc...). Ahora si lo intento en Mac se cuelga vClient.
No se por donde tirar.
Gracias
Overall


([N4] agonzalez.velneo.com) #7

Hola Overall:
Te recomendamos que realices dos cosas:

1) Añade en el mensaje "Documento leído" la variable DOCUMENTO, correspondiente a la senda del documento que quieres leer. De esta forma podrás ver que es lo que realmente existe y se intenta leer.

2) Para simplificar el tema y probar el comando "Ejecutar documento", haz un proceso sin origen que en primer lugar te pida seleccionar el documento a ejecutar y a continuación lo ejecute. Añade este proceso en una acción y asociala al menú principal. De esta forma eliminamos parámetros de la ecuación que puedan estar afectando al resultado.

Un saludo.


([N2] overall) #8

Hola agonzalez,
No me funciona de ninguna de las maneras. He realizado las dos sugerencias:
1- La senda es correcta, adjunto imagen.
2- Tampoco me funciona con este proceso que te adjunto y la senda también es correcta.
Lo he probado en distintos ordenadores y con distintos formatos de archivo.
Hay algo que no funciona y no se por donde tirar.
Gracias
OVerall

[attachment=1668,178] [attachment=1668,179]


([N4] agonzalez.velneo.com) #9

Hola:
Mándanos a la cuenta soporte@velneo por favor los datos de acceso a la aplicación para tratar de ejecutarlo nosotros desde una máquina donde nos funcione el comando y así ir descartando temas. Los datos necesarios son:
Servidor:
Usuario:
Contraseña:
Solución:
Caja:
Proceso:

Un saludo.


([N2] overall) #10

Así lo haré, muchas gracias


([N4] agonzalez.velneo.com) #11

Hola Overall:

En primer lugar quisiéramos agradecerte tu colaboración para resolver esta incidencia.

Respecto a la parte técnica, decirte que efectivamente hemos reproducido la incidencia, tanto en el acceso a tu aplicación como posteriormente en nuestro laboratorio. Lo que sucede es que el comando "Ejecutar documento", no funciona correctamente cuando en la senda existe espacios en blanco.

Hemos recogido el bug en nuestro sistema de gestión de incidencias con el código nº 001241.

Con este código puedes hacer referencia a la incidencia en el caso de que quieras conocer su estado en el futuro.

Queremos agradecer tu colaboración ya que con ella estás ayudando a mejorar Velneo V7.

Saludos