Instalar vSrever en Linux Ubuntu 11.04


([N1] pedrosas) #1

Quiero compartir como he instalado el vServer con aranque automatico en y con el usuario root en el puerto 690

He colocado la carpeta vServer en home/usuario/velneo/vServer

Arranque automatico como root
he creado un script s999vServer.sh en la carpeta etc/rc2.d/s999vServer.sh con las instrucciones de arranque
./home/usuario/velneo/vServer/vServer.sh -s

Cierre automatico como root
he creado un script k999vServer.sh en la carpeta etc/rc2.d/k999vServer.sh con las instrucciones de parada
./home/usuario/velneo/vServer/vServer.sh -t

espero que os sirva

Pedro Sastre


([N1] comercial) #2

Hola, muchas gracias por la info...

Saludos.
Miguel.




([N1] r_baena) #3

Hola. Muchas gracias por el aporte.
He hecho lo que indicas y no me funciona. No arranca el vServer. Hace falta alguna instrucción más, como ln o algo parecido?


([N4] mittosoftware) #4

Yo sigo con el problema de que no se ejecuta cada vez que encienden el servidor, sino que hay que escribir a mano el -s. Es decir, funciona, pero no auto-arrance

Yo he hecho lo sugerido acá (usando etc/rc2.d), y el servicio arranca (comprobando con -v), pero al querer usar mi app, es como si se borraran los usuarios.vsi porque solo se puede entrar con usuario ‘Velneo’ ( password vacio, como cuando uno recien instala).

Cuando pasa esto, se le da -t y otra vez -s y todo vuelve a la normalidad. Pero no hay como quede ‘bootable’.

¿Ha alguien mas le ha pasado?, ¿alguna sugerencia adicional? Uso la 7.14.3 en un Ubunto server 12.04