Instalar vServer en linux 64 bits


([N3] Jose) #1

Buenos días al foro.

Estaba intentando instalar un vServer 7.16 en un servidor linux CENTOS 7.0 64 bits más que nada para probar su rendimiento,
ya que hasta ahora los había instalado todos en windows.

Y la verdad estoy un poco perdido ya que, al ser 64 bits, por los visto tengo que instalar para que funcione la compatibilidad de las librerias para 32 bits.

Podría indicarme alguien los pasos a seguir para realizar la instalación correctamente?.

Perdonad mi falta de conocimiento al respecto.

Gracias de antemano.

Saludos.


([N3] Humber) #2

Buenas @Jose te compartiré esta publicacion que tiene todos los pasos a seguir para instalar vServer en linux… En tu caso que es de 64 bits y creo que este no toca este tema, pero es uno o dos comandos mas.

http://exprimiendovelneo.wordpress.com/2012/02/06/instalar-velneo-vserver-v7-en-linux-y-no-morir-en-el-intento/

si mal no recuerdo se llama ia32libs o algo así…

Saludos.


([N3] Jose) #3

Hola Humber. Antes que nada agradecerte tu interés.
Ya había leído el artículo que mencionas, pero el problema creo que está en instalar las librerías para 32 bits para que funcione vserver en un sistema de 64 bits.

Gracías de todas maneras.

Saludos.


([N3] Jose) #4

Solucionado!!


([N3] Humber) #5

Puedes compartir tu solución para otros miembros que vengan con la misma duda puedan resolver. :slight_smile:


([N3] Jose) #6

Buenos días.

Al final lo puede instalar de la siguinete manera.

Una vez descomprimido el vServer.

Al ejecutar sudo ./vServer.sh -i me daba error poruqe faltaba el soporte para librerias de 32 bits que le hacen falta a vServer para ejecutarse.

Lo que iba haciendo era ir instalando las librerias que me pedía “yum install nombrepaquete”.

Al final me instaló el servicio.

La primera vez un poco costoso pero cuando ya sabes de que va pienso que será más sencillo.

Saludos.


([N2] japps) #7

Buenos días,

estoy intentando instalar el vserver 7.19.1 en un VPS con Centos 7.1 64 bits (sin interfaz gráfico), pero no he conseguido localizar las librerías dependientes de 32 bits.

Estos son los errores que me dan:
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

error while loading shared libraries: libpulse.so.0: cannot open shared object file: No such file or directory

Estoy un poco pez con linux. He intentado localizar repositorios para añadirlos y poder instalar con yum pero no lo he conseguido.

No se si me podéis ayudar con esto?

Me gustaría una vez que lo consiga hacer un post con los pasos detallados, para ayudar a quien como yo se topa con estos problemas.

Un saludo,
Juan Antonio


([N2] jorge) #8

Buenos días Juan Antonio,

Prueba con esto:

apt-get update
apt-get upgrade

apt-get install libglib2.0-0
apt-get install libgl1-mesa-glx
apt-get install libpulse0

Un saludo.

Jorge


([N1] jecc) #9

Buen dia…

Auxilio, tengo una inquietud en el titulo de debate “Instalación vServer 21.2 Linux”
A Alguien mas le ha sucedido o tienen alguna idea ?
Gracias,


([N2] japps) #10

Buenos días,

gracias por las respuestas, ya he conseguido que funcione instalando las siguientes librerías:

yum install pulseaudio
yum install mesa-libGL

Ahora me falta configurar un servicio para que arranque automáticamente…

Un saludo,
Juan Antonio