Informe Blanco


([N1] tamaramaldonadosoto.hotmail) #1

Buenos días,

Ando peleandome con un informe, se nota que estoy empezando con V7.....

He creado un informe con su tabla asociada correspondiente. Compruebo vía mensajes que me carga bien la lista, pero luego no me imprime nada. Un folio en blanco, ni las imagenes.

Alguien me puede decir que concepto básico me falla?

Gracias


([N1] Velasco) #2

Buenas Tamara

Podrías explicarnos como haces para presentar el informe?

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com


([N1] tamaramaldonadosoto.hotmail) #3

Hola Jorge,

Te adjunto la imagen del evento a través del que lanzo el informe.


([N1] Velasco) #4

Buenas.

Falta la foto ;)

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com


([N1] tamaramaldonadosoto.hotmail) #5

Uy, no me he dado cuenta que me había dado error en la subida de la imagen


([N1] tamaramaldonadosoto.hotmail) #6

Esta visto que hoy no es mi día.. no me deja subir imagen, ya me pelearé con ello más tarde... jeje

Te lo intento comentar.

-Creo manejador de objeto busqueda

- Creo manejador de objeto informe

-disparo objeto busqueda

- selecciono ficha por posicion

- leo ficha seleccionada

-y disparo objeto  informe

 

Gracias por la paciencia :)


(ame) #7

Hola Tamara,

 

Pues depende de como lances el informe. Recuerda que el informe, al igual que todos los objetos, recibe una entrada y produce una salida. El informe se alimenta de una lista, lista de registros que serán del tipo de la tabla que hayas asociado al informe. Así pues, para que el informe muestre datos, deberás alimentarlo con esa lista. Tienes muchas opciones, con acciones disparando objetos, desde un proceso con la instrucción "Añadir lista a la salida", etc.

Lo mejor es que consultes el manual y veas algunas Open Apps.

 

Saludos.

 

José Luis.

 


(ame) #8

Acabo de leer tu mensaje, como bien he dicho en mi primer mensaje, recibe una lista, y tú estás tratando de pasarle una ficha, lo cual no es correcto. Corrije ese fallo y verás como de pronto te funcionará el informe.

 

Si lo que quieres es mostrar sólo una ficha en el informe, haz que la búsqueda devuelva entonces una lista de un sólo registro. Resuelve el componente de búsqueda por algún campo del que estés segura que te va a devolver una sola ficha (campo clave), como por ejemplo el código.

 

Un saludo.

 


([N1] tamaramaldonadosoto.hotmail) #9

Sabía yo que era algo básico, me faltaba una sentencia "añadir lista al objeto".

Muchas Gracias a los dos :)