Imprimir Información de una Tabla


([N1] laurent) #1

Hola buen día.

Primero que nada comentar que soy totalmente nuevo en velneo y en lenguajes de programación, buscando información me encontré con velneo y aunque no se prácticamente nada me llamo mucho la atención lo rápido que se puede hacer algunas cosas, bueno mi pregunta una vez habiéndoles dicho que soy poco menos que novato en esto, es que no puedo lograr que salga la información de una tabla en la vista previa de impresión.

Tengo un objeto Informe el cual le asocio la tabla que contiene la información que quiero poder imprimir y tengo una Acción la cual dispara el objeto Informe y al ejecutarlo me abre la vista preliminar de impresión (porque así lo configure con vista previa) pero siempre aparece la hoja en blanco, ya estuve viendo otros hilos pero de igual forma no doy con la solución, les repito que soy muy pero muy novato.

Agradezco su tiempo y si alguien pudiera ayudarme se los agradecería mas.

Saludos!


([N1] wikan) #2

Buenas y bienvenido,

te faltaría alimentar el informe con los datos que quieras, puedes usar una búsqueda o un cargar lista.

Luego tengo de un origen de lista, es decir, debajo de la búsqueda o el cargar, ejecutar el informe, para que éste tenga datos que imprimir.


([N1] laurent) #3

Muchas gracias por tu tiempo, te comento, estuve tratando de hacer lo que me dijiste, sin embargo sigo con el problema, inclusive en mi afán de poder conseguirlo hice varias configuración (combinaciones posibles) pero siguió igual, adjunto una captura de la acción donde disparo la búsqueda y después el informe.



([N2] Mgalvezh) #4

Hola, pon una rejilla después de la búsqueda para saber si te devuelve registros.

Saludos.
Miguel.


([N1] laurent) #5

Hola! gracias por tu tiempo, hice lo que me comentaste y si saca la tabla con la información que contiene, pero para imprimir no me muestra la información, me sigue sacando la vista previa en blanco, un dato que me di cuenta es que creo (ustedes estoy seguro sabrán mas de esto) en una parte de la configuración para la vista previa de impresión podía sacar una hoja para cada registro, y en la previa me sacaba 3 hojas y yo tenia 3 registros en la tabla, le agregue un registro nuevo y me aparecieron las 4 hojas, pero todas en blanco.

Saludos!


([N1] wikan) #6

Buenas,
¿estás poniendo la información en la sección del detalle?
En teoría si te está mostrando algo tan mal no vas, quizás tienes marcado algo para hacer el salto de página. Prueba a poner un campo en la sección del detalle.


([N1] laurent) #7

Muchas gracias a los dos, creo que ya di con el problema, obviamente guiado por ustedes, se los agradezco mucho!

Saludos!