Formulario de login


([N2] vazuara) #1

Buenas tardes,
Agradeciendo su ayuda, les comento mi problema:
Tengo un formulario (no tiene tablas asociadas) con 2 cuadros de texto (usuario y contraseña) el cual lo tengo como formulario principal del autoexec, al iniciar la aplicacion todo aparece como debe, pero a la hora de escribir el usuario y pasarme al campo de contraseña o viceversa, el campo en el que acabo de escribir se vacia de forma automática, ya lo probe asignando una tabla y sigue haciendo lo mismo, alguien sabe que estoy haciendo mal?


([N1] wikan) #2

Buenas, ¿le has puesto contenidos a los cuadros de texto?, le asocias una variable local, ya que no usas tabla de origen


([N2] vazuara) #3

Disculpa pero soy muy nuevo en velneo y no se como hacer lo que me dices


([N1] wikan) #4

Hombre, aunque pongas los cuadros de texto, debes decirles que contenido van a guardar, ya sea una campo de la tabla, una variable (global o local).
Pues lo dicho, debes poner que contenido van a guardar o usar esos cuadros de textos, ya luego mediante un evento o un proceso, las usaras para verificar el usuario


([N1] Pepeto) #5

Para hacer un formulario de Login personalizado, necesitas:

  • una tabla de usuarios, donde guardar sus nombres y claves
  • un formulario, logicamente, donde pedir el Usuario y la Clave de acceso
  • un proceso que verifique el usuario y la clave y que te permita el acceso o te pida nuevamente los datos si no son correctos.

Se puede hacer de varias formas, pero en cualquier caso, deberas pedir los datos desde el formulario principal de la aplicacion.

un saludo
José Luis
http://www.ascsl.com