Formulario con rejilla tarda mucho en cargar


([N1] alamillos) #1

Hace tiempo que estoy intentando dar la solución a este asunto, se han puesto hilos en el for, los he leido y bueno no encuentro la solución, una tabla plural de varias tablas ejemplo un asiento contable enlazada a la tabla plan general contable, enlazada tambiem a proveedores , enlazada a años , enlazada a tipos de iva, a centros de trabajo. si se carga en un formulario tarda muchisimo, no es precisamente por los campos formulas sino por los enlaces, porque claro cada enlace tiene un indice.

Teneis alguna solución para esto?
Muchas Gracias
Juan Díaz


([N1] filipeagg) #2

Hola Juan,

Revisa este hilo, al mejor si haces lo que se propone en el hilo, mejoras algo, si bien que como tu problema son los enlaces no estoy muy seguro.


([N4] eic) #3

Hola.

No tengo muy claro a qué te refieres: ¿es un simple formulario, donde muestras los datos del asiento, junto con información de las tablas enlazadas (p.ej., muestras el nombre del proveedor, la descripción del tipo de IVA, el nombre del centro de trabajo, etc.? ¿Sin ningún separador, ni visores de datos, ni nada, y sólo el formulario a pelo? Pues me extraña que te tarde tanto. ¿Hay alguno de los enlaces que no sea enlace a maestro, y sea indirecto? ¿Tienes condiciones de visibilidad complejas en los campos?

Saludos,

Fran Varona


([N1] alamillos) #4

Muchas gracias, el formulario es un simple formulario del centro de producción, y la rejilla es asientos simples, nadamas, lo he probado todo, y nada me tarda 45 segundos con 100 registros, no tiene visoresm si existen enlaces2 enlaces indirectos podria ser eso?
probaré y os comento.


([N2] AyudaVelneo) #5

Hola Juan:

Son los enlaces indirectos. Nosotros teníamos en una ficha de entidades tres enlaces indirectos dentro de un separador. Incluso aunque no mostrasemos la pestaña donde se encontraban los campos, al mostrar el registro tardaba una eternidad.
V7 carga todos los controles antes de mostrarlos.

Un saludo


([N1] alamillos) #6

Muchas gracias ayudavelneo,
entonces como habeis solucionado el problema?, porque para la apliación que estoy haciendo es indispensable tener enlaces indirectos.
Juan Díaz


([N4] eic) #7

Hola.

Aunque tengas el enlace, puedes guardar en la propia tabla la información que quieras mostrar (en otro campo, con contenido inicial), de modo que en la rejilla usas el campo de la propia tabla, y así no tiene que resolver el enlace para mostrar la información.

Saludos,

Fran Varona


([N2] AyudaVelneo) #8

Hola Juan:

Se me adelantó Fran… lo que hicimos fue lo que te ha explicado Fran… y quitar alguno que no era necesario.

Un saludo


([N1] alamillos) #9

Pues muchisimas gracias por darme la solución.
Juan Díaz


([N1] anghelusdark) #10

Buen día Juan Díaz mi nombre es Eduardo y quisiera saber si tienes un correo en el cual pueda contactarte pues tengo algunas dudas acerca de una pregunta q hiciste sobre velneo hace mucho tiempo gracias


([N1] alamillos) #11

Buenos dias Eduardo mi correo es: jdalamillos@hotmail.com
Estoy a tu disposición.
Saludos
Juan Díaz.