Estoy creando menús, dos problemas 1º no saca el título, 2º no refresca bien.


([N1] J.Jiménez) #1

Estoy creando menús, imaginemos mi caso Menú principal->Maestros->Entidades.

Si creo primero Entidades, luego el menú de maestros y luego menú principal me van apareciendo en la lista para asociarlos sin problemas, pero si lo hago al revés existen pero no me aparecen.

Para que aparezcan debo de cerrar vDevelop y abrirlo de nuevo.

 

Además les tengo indicado que muestren Icono y Título, y muestran el icono los que se lo he asignado pero en ningún caso el título.

 


([N4] rcueto.velneo) #2

Hola:

Si tienes abierto el editor de un menú concreto, si añades nuevos menús o acciones en el mapa, para poder refrescar la lista de acciones disparables en el editor de dicho menú, no tendrás más que cerrar el editor de ese menú y volver a abrirlo nuevamente (adjunto imagen explicativa).

En lo que se refiere al titulo de cada menú incluido dentro de otro menú, asegúrate que en las propiedades de ese menú que has incluido en el otro hayas cumplimentado el parámetro “Nombre”.

Un saludo.

 

[attachment=4355,463]


([N1] J.Jiménez) #3

Si, todos tienen nombre y por si acaso también comentario.


([N4] rcueto.velneo) #4

Hola:

Eso es indicativo de que estás hablando de menús incluidos como opción dentro del menú usado como menú del marco de la aplicación.

En ese caso debes saber que ocurre lo que comentas; si el menú tiene asociado icono solamente se presenta éste y no el texto. Es algo que tenemos recogido en nuestro sistema de gestión de incidencias con el código 857.

Te aconsejamos que, por tanto, en los menús que incluyas como opciones del menú principal de la aplicación, no uses icono.

Un saludo.