Error en Tutor vNCReport


([N1] ViperNET) #1

El problema es que algunos informes de este tutor no se ejecutan.

El día de ayer por la noche estuve revisando el código del Tutor vNCReport para encontrar la razón del porqué no se ejecutaban los reportes de “código de barras”, “lista agrupada” y “lista de países con banderas”. Y encontré el error.

El problema es que en los procesos que generan los reportes en cuestión… IMPRIMIR_LISTA_DE_PAISES_Y_BANDERA, IMPRIMIR_EJEMPLO_CODIGO_DE_BARRAS y IMPRIMIR_EJEMPLO_LISTA_AGRUPADA…se está direccionado al directorio tempPath() y no al directorio de caché que está especificado en la variable global “$NCREPORT_WORKING_DIR@vNCReport_dat.dat” tal como lo hacen en el procedimiento PREVIEW_PAISES.

Para corregir, lo que debemos hacer es reemplazar las primeras 6 líneas erróneas por las siguientes “ver imagen 1″:
[attachment=25000,1961]

Y la línea que ejecuta el ncreport, por esta “ver imagen2″:
[attachment=25000,1962]

Como pueden ver, aquí una muestra del informe de códigos de barras generado.
[attachment=25000,1963]

Espero les sea de mucha ayuda.
Saludos,
Victor








([N1] Synetic) #2

Gracias ViperNET.


([N1] Pepeto) #3

Gracias por la info.

un saludo
José Luis
http://www.ascsl.com


([N1] ViperNET) #4

De nada.


([N4] velavisual) #5

@ViperNET
.
.
Gracias, con tu permiso copio pantallazo para cuando disponga de vNCReport
.
.
saludos
Antonio Vela
http://www.velavisual.com


([N4] jmgonzalez.velneo) #6

Vaya. Muchas gracias. Los cambios de última hora es lo que tiene.

Hemos actualizado a la versión 1.0.1 la Open App vNCReport corrigiendo este bug. Gracias a todos por vuestra colaboración.

Saludos


([N1] Synetic) #7

Solicitando enlace de descarga para bajar la 1.0.1 sigue siendo el mismo. Se me descarga la versión 1.0


([N4] jmgonzalez.velneo) #8

@fernando: Corregido. Gracias por el aviso y sentimos las molestias


([N4] velavisual) #9

@ALL
.
En la web de Nocisoft, se indica que la última versión es la 2.8.4.
.
Mi pregunta es:
.
¿Cada vez que actualice Nocisoft se puede sustituir los ejecutables y librerías correspondientes en la Open Apps en curso?
.
Ejemplo: Sustituir los ejecutable de la 2.8.3 y librerías por los de Nocisoft 2.8.4 (que según su editor e información que sale en pantalla es versión de evaluación) pero dicen que es más rápida.
.
¿Afecta esto en algo a la Open Apps?
.
.
saludos
Antonio Vela
http://www.velavisual.com


([N1] info) #10

Una pequeña duda, en la versión que me he bajado hoy mismo, no existe ningún diseño definido antes.
¿Es así en todos?