error con version de android


([N3] Servinfor) #1

Hoila he hecho una aplicación que lleva un año funcionando correcta en Android 4.1 Ahora he comprado otra tablet con la versión 4.2.2 y se me cuelga la aplicación, las pantallas emergentes salen desconfiguradas y no caben en la pantalla al tocarlas se cierra la aplicación Las otras tablets que usan con la 4.1 siguen funcionando correctamete

¿A alguien le ha pasado?


([N1] MATIAS) #2

Hola,

yo he hecho algunas pruebas para ver cómo funcionaba el vClient en Android y te he de decir que los resultados dependen del terminal donde se ejecuta.

  • En mi vieja tablet Samsung Galaxy 10.1 con Lollipop 5.1 funciona Ok.
  • En un Doogee x5 Pro (terminal chino de 90€) con Lollipop 5.0 funciona Ok.
  • En Sony Xperia Z2 con Lollipop 5.1.1 falla el vClient cerrándose una vez que te logas. Y cuando se conecta, las pantallas salen desconfiguradas.

Por lo que he leído en el foro, lo de las pantallas parece debido al dot-pitch. Pantallas con mayor resolución provocan estos problemas.

A ver si alguien nos aporta mayor información al respecto.

Un saludo!


([N3] Servinfor) #3

Gracias Matías por tu información, si lo de las pantallas emergentes desconfiguradas y que se cierra me pasa en la versión 4.2.2

Pienso que Velneo debía probarlos en todas las versiones de Android y descubrir por qué fallan si en 5.1 y 4.2 fallan habrá que saber por qué

Así no podemos vender a nuestros clientes que somos capaces de crear apps para móviles, en concreto un cliente que tenía 2 comerciales funcionando bien con tablets antiguas se compra una nueva gastandose 300€ y no funciona

Ya imagino que es complicado para el departamento de velneo probarlo todo, confiemos en que pronto lo solucionen pues suelen ser rápidos cuando detectan los problemas


([N1] MATIAS) #4

El problema de Android es lo “atomizado” que está, ya no sólo a nivel de terminales, sino de versiones de S.O. Incluso, dentro de una misma versión los fabricantes “personalizan” sus dispositivos con “modificaciones” sobre el mismo S.O., lo que lo hace un campo difícil de pruebas.

Si es cierto que se podrían publicar por parte de Velneo de una lista de terminales y versiones de Android donde el vClient funciona con normalidad. Creo que con esto nos evitaríamos estar “probando” o llevándote una desagradable sorpresa.

Yo no creo que sea tanto un problema de versión de Android como de resolución de pantalla. Cuanto más “caro” es un terminal, con lo que se le supone mayor resolución de pantalla, tiene mayores problemas.

Un saludo!


([N3] ereitmann) #5

alguien sabe si una lenovo.10.1 yoga2 z3745 con android 4.4 andaria bien? un cliente le ofrecen comprar varias con esa configuración pero no se como correria el vclient