enviar mails automaticos


([N3] Servinfor) #1

Hola, quiero a partir de una lista de mails que he genero creando un csv que se envien automaticamente. He visto que con el mailto puedo hacer que se abra el outlook pero no se envian automaticamente, cual es la mejor forma para hacerlo?


([N1] wikan) #2

Buenas, usa dll o exe vía línea de comandos. Es la manera mas transparente


([N3] Servinfor) #3

Hola Manuel, gracias pero tienes algún ejemplo que me oriente?


([N1] wikan) #4

@servinfor de envio a listas no, yo uso vSendmail para el envio de correos.
Podrías convertir esa lista, lista de destinatarios y enviar el mismo mail a todos, en vez de uno a uno.

Solo tendrías que hacer uso de la función de vSendmail


([N4] apinna.winmotor) #5

@servinfor nosotros utilizamos Vmailwin, es una open-app de Velneo. Está algo anticuado pero sirve para envío y recepción de correo electrónico y queda completamente integrado en la aplicación.


([N1] playa1) #6

se puede usar gmail?


([N4] carlitos) #7

sí, yo uso cobn cuentas google apps, y funcina lamar de bien.
cuando lo uso con cuentas de un servidor estándar, tipo abserver, tengo problemas con la validación.
estoy utilizando la versión de vsendmail que sale en la app de velneo, pero no me envíua fuera del dominio.
sin embargo, con la versión 1.17b.15 funciona, pero no es del todo estable, ya que no me adjunta bien los pdf,s ni los html,s

@wikan, ¿que versión utilizas?


([N1] wikan) #8

@carlitos, ahora de memoria no recuerdo, pero es la 1.17, pero no de las últimas.
Te lo miro luego y te digo


([N4] carlitos) #9

ya me dirás


([N3] veldevelop) #10

Yo os recomendaría que probarais con python, quizás sea un poco más complejo al principio pero os aseguro que la pelea merece la pena. Si el server está en Linux lo tendréis muy fácil y si lo tenéis en windows podéis instalar python 2.7 Ojo si os animáis a montar python 3.0 tendréis que tener en cuenta que las funciones y parámetros de smtp son algo ligeramente distintas y por tanto los scripts para la 2.7 simplemente no funcionaran en la 3.0


([N1] wikan) #11

Buenas @veldevelop, estoy usando la 1.17b4, algo viejita por lo veo