Eliminar ficha con historicos


([N1] mauricio.gonzalez.telefonica) #1

Hola a todos, tengo una tabla MEDICIONES submaestra de PARTIDAS submaestra de CAPITULOS submaestra de PROYECTOS.

Cuando trato de eliminar una ficha de PARTIDAS con historicos (MEDICIONES), me rompe el vClient, disparo una conexion a un evento desde un boton situado en un formulario de edicion de la ficha PARTIDAS a eliminar, el boton tiene seleccionado el comando eliminar. adjunto imagenes, gracias...

[attachment=2196,220] [attachment=2196,221] [attachment=2196,222]


([N4] rcueto.velneo) #2

Hola:

Intentaremos reproducirlo en laboratorio. ¿Podrías decirnos cuál es la señal que dispara este evento que comentas?

Gracias por tu colaboración.

Un saludo.

 


([N1] mauricio.gonzalez.telefonica) #3

Hola rcueto,

formulario: partidas edit

boton incluido en el formulario (nombre): eliminar

comando del boton: eliminar

conexion de evento asociada a: boton eliminar

señal: gana foco

lo que pretendo es que al pulsar el boton eliminar, primero me elimine los historicos (plurales) mediante el proceso descrito en foto 2 y despues el comando propio del boton me elimine la ficha una vez libre de historicos,

No se  si esto responde a tu pregunta?, gracias....

 


([N4] fgutierrez.velneo) #4

¿Tienes actualizaciones desde los históricos al maestro?

Un saludo.


([N1] mauricio.gonzalez.telefonica) #5

Hola fgutierrez, no tengo actualizaciones, el caso es que solo rompe el vClient, si lanzo el proceso de eliminacion de los historicos desde un boton con el comando eliminar en un formulario modal,  si lo lanzo desde ese mismo boton, colocando el mismo formulario en un bloc de formularios funciona sin problemas, realizando la baja de los históricos y despues elimiando la ficha sin problemas.


([N4] rcueto.velneo) #6

Hola:

Hola fgutierrez, no tengo actualizaciones, el caso es que solo rompe el
vClient, si lanzo el proceso de eliminacion de los historicos desde un
boton con el comando eliminar en un formulario modal,

Hemos intentado reproducirlo siguiendo tus indicaciones pero no lo hemos logrado. Hemos probado con un formulario con la propiedad "Cuadro de diálgo" tanto activada como desactivada, pero no rompe Velneo vClient V7, así que ha de haber algún otro factor que interviene en tu caso que no hemos tenido en cuenta.

No obstante, ¿porqué no haces el borrado de los históricos desde el propio evento previo a la baja de su maestro?

Un saludo.


([N1] mauricio.gonzalez.telefonica) #7

Hola rcueto, así tambien lo habia probado y me daba el mismo error, si no podeis reproducirlo seguro que estoy haciendo algo incorrecto, voy a repasarlo todo y si no encuentro la solucion, vuelvo a postear, gracias...


([N4] rcueto.velneo) #8

Hola, mjgm:

Gracias a tí por tu colaboración.

Un saludo.