Duda multiidioma


([N1] agustin) #1

Buenos días: se comentó en algún hilo del foro, no recuerdo cuál, que para que el multiidioma funcione bien , el usuario ha de tener instalado la versión del sistema operativo en el idioma que se quiere ejecutar la aplicación

¿Es esto así o me equivoco?

Gracias.


([N1] Velasco) #2

Buenas Agustín.

Había una incidencia con los idiomas.

Si no recuerdo mal, sólo funcionaban directamente el español y el inglés.

Si querías, por ejemplo que estuviera en catalán tenías que tener el s.o en catalán.

Pero no estoy seguro. He estado buscando el post y no lo he encontrado.

Un saludo.

 

 

Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com

 


([N4] eic) #3

Hola.

Tampoco lo he probado mucho, pero creo que ocurre lo que dice Jorge, por lo siguiente: la única manera de cambiar el idioma de la aplicación es utilizar una opción estandar que te presenta los idiomas en el menú de la aplicación. Pero está sólo limitado, de momento, a español o inglés. Si necesitas otro idioma, no te aparece en la lista, y sólo se activa si el S.O. está en ese idioma. Puedes hacer todo el desarrollo (formularios, etc.) en, digamos, catalán, pero el usuario sólo lo verá si el S.O. está en catalán, porque no hay forma de seleccionar ese idioma desde el menú.

Saludos,

Fran Varona

 


([N1] agustin) #4

Gracias a los dos por responder. Yo también había buscado ese post y no lo lograba encontrar.

De nuevo gracias y un saludo.


([N1] Velasco) #5

Buenas

Encontré este post: http://velneo.es/foros/topic/lenguaje-en-mensaje-de-procesos-o-eventos . Pero creo que había alguno mas

Un saludo.

 

 


Jorge Velasco Fernández

jvelasco@theseedsc.com

www.theseedsc.com


([N1] Rafael) #6

Hola Agustín,

El Post del que habla lo Inicié yo , ya que estoy haciendo una aplicación que debe ir en 5 idiomas. El tema es el siguiente:

No necesitas que el usuario tenga el S.O en otro idioma. Lo que si se necesita es tener en la configuración regional el país que necesitas. Así, puedes tener un S.O en español pero tener configurado como país en la configuración regional Francia (por ejemplo).

Por defeto, como bien dice Jorge, sólo aparece el Español y el Inglés. Así que "la moto" de que con solo añadir paises a las cajas y despuéss utilizar el vTranslator todo estaba hecho no funciona. A ver para cuando...


([N1] agustin) #7

Buenas tardes: rzaragoza.dinacom, gracias por la aclaración de la configuración regional

Un saludo.