Duda en Relacion de Tablas...!


([N1] leonardo daniel velazquez fuentes) #1

Hola a todos de nuevo, tengo un proyecto que tengo que realizar, sera mi primer proyecto en forma en Velneo V7, pero me surgio una duda, ya que en una de las tablas Viajes (Loads) debo tener 2 campos, chofer1 y chofer2, esto si se cumple la condicion de marca el campo Single/Team como Team ( viaje en equipo ), bueno cree el campo chofer1 y le di relacion maestra a choferes, luego cree el campo chofer2 e hize lo mismo, pero solo me aparece una linea de relacion, pero en la tabla de viajes me aparecio solo un indice CHOFERES y revise el indice y no estaba ligado no chofer1 ni al 2, asi que lo ligue al chofer1, luego lo duplique chofer2 y apunte a chofer2… lo mismo sucede con las ciudades y estados, estado origen - estado destino, ciudad origen - ciudad destino… hago lo mismo ??? ya que no me aparecio ningun indice ni apuntanto a estados ni tampoco a ciudades.!! mi pregunta es… son necesarios esos indices. ??? lo pregunto por lo de LOS PLURALES… ahora en la tabla de choferes si me aparecen los plurales chofer1, chofer2, apuntando a viajes

les dejo imagen del esquema y tablas


([N1] leonardo daniel velazquez fuentes) #2

mmm que raro, ya no es novedad que no suba los archivos






([N1] leonardo daniel velazquez fuentes) #3

Que paso ?? nadie ??? mm soy nuevo… entonces asumire que hize lo correcto al ligar cada campo individual hacia sus respectiva tabla de choferes, hare lo mismo con la tablas de estados y ciudades y a ver que pasa


([N1] wikan) #4

Si haces copia/pega no te crea los índices de manera automática. Solo lo hace mediante el botón superior de añadir maestros.

En principio en mi opinión es el esquema correcto.


([N1] leonardo daniel velazquez fuentes) #5

Ahh ok, no me sabia eso del copiar y el pegar…!

gracias