Drag&Drop


([N2] bannu) #1

¿Funciona en la 7.6?, la función drop lee correctamente los datos, y da de alta en la tabla de destino, pero no refresca el objeto que contenedor, no funciona ni en las open apps, ni en el tutor de drag&drop.


([N2] gegeo) #2

JO DER

Acabo de probarlo, y peta.

ESTO NO ES SERIO.
Cuando ya conseguimos dejar algo funcionando, y seguimos peleando en otros menesteres, viene la siguiente versión y ZASCA, en TODOS LOS DIENTES.

¿SOLUCION? ¿Una idea, un bug, un foro,....?


([N1] Velasco) #3

Buenas.
Lo primero tranquilidad. ;)
En la rejilla del drop estáis dando una alta, no?
Si es así en el proceso drop de la rejilla, dentro del alta de ficha poner: Añadir ficha a la salida.
Yo lo tengo así y me funciona perfectamente, en la 7.6, la 7.5, etc...
Un saludo.


Jorge Velasco Fernández
jvelasco@theseedsc.com
www.theseedsc.com


([N2] bannu) #4

¿No querrás decir añadir ficha a la lista ?, deberías revisarlo, porque a mi no me funciona.


([N1] Velasco) #5

Lo acabo de probar Nacho y me va perfectamente.
Mi caso son dos rejillas dentro de un formulario y arrastrod euna rejilla y doy altas en la otra y me refresca perfectamente.
Un saludo


([N2] bannu) #6

Yo arrastro desde una lista de un formulario contenido en un splitter hacia otra (tabla en memoria) dentro de un form cargado en un objeto, pero todo en global está en el mismo form, y que si quieres castañas, apelativo que cada vez me siento más tentado en utilizar para definir a la V7.

Además, aunque no presente ninguna ficha en la lista, si despliegas el menú contextual y seleccionas modificar campo te saca el formulario para realizar los cambios, y las otras opciones pues más de lo mismo, si la lista está bacía, las opciones deberían estar deshabilitadas, digo yo, viva la fiestaa.