Correo electrónico con Vmail


([N4] apinna.winmotor) #1

Hola a todos,

como ya sabemos las librerias de Vmail para sistemas de 64 bits van regular pero por motivos que no voy a contar las tengo que poner en marcha y en cada máquina con Windows Vista o Windows 7 en las que lo intento es un mundo.

El caso es que después de algunas máquinas en las que hemos conseguido ponerlas en marcha, estoy ahora en un servidor en la nube y tengo los siguientes errores :

ENVÍO :

aparece en la barra de mensajes un error número 10030 (no está catalogado en la lista de errores). Consultando el log aparece lo siguiente :

QUIT
09/12/12 12:26:50 Opening Socket.
Connecting to: smtp.winmotor.net

RECEPCIÓN:

aparece en la barra de tareas el error 40030 que tampoco está catalogado y en el log inexplicablemente no escribe nada.

¿alguna idea ?

Saludos a todos


([N1] filipeagg) #2

Tiene toda la pinta de ser el firewall que bloquea las conexiones.
Verifica el firewall de windows (conexiones entrantes y salientes), y también el firewall de la nube, si lo hay.


([N2] ramiro) #3

Buenas:

Supongo que es obvio, pero… ¿habéis registrado las librerías? ¿Se registraron correctamente?

Aun no he usado esas librerías con V7, pero si las uso con V6 y el registro en sistemas de 64 bits es un auténtico tormento que funciona cuando le da la real gana.

Saludos. Ramiro


([N1] Mario) #4

Si no me equivoco, no puedes enviar mail desde servidores en la nube, ya que Amazon los capa si no están registrados en su BBDD (temas de SPAM)

Saludos


([N4] apinna.winmotor) #5

Muchas gracias a todos, ya he dado con el problema y es como casi siempre, surrealista :

TODO ESTABA EN QUE TENÍA MARCADO EL PARÁMETRO SSL EN LA CONFIGURACIÓN DE LA CUENTA Y EL SERVIDOR DE CORREO EN ESTE CASO NO LO SOPORTA. INEXPLICABLEMENTE, EL ERROR EN LA RECEPCIÓN SE HA CORREGIDO TAMBIÉN DESMARCANDO EL PARÁMETRO.

Ramiro, en cuanto a registrar las dll en sistemas de 64 bits te doy toda la información que tengo, nosotros lo conseguimos en todos los casos:

  1. En sistemas de 32 bits se registran sin problema en c:\windows\system32

  2. En sistemas de 64 bits se hace en c:\windows\syswow64 y hay que tener en cuenta lo siguiente:

Existen en estos sistemas dos aplicaciones distintas REGSVR32.EXE, una en el directorio c:\windows\system32 y otra en c:\windows\syswow64. Lo alucinante (las cosas de Microsoft) es que una es de 32 bits y la otra de 64 y no lo ves por ningún sitio.

Osea, asegúrate cuando quieras registrar las dlls en sistemas de 64 bits que estás ejecutando el REGSVR32 correcto

Muchas gracias de nuevo, llevo dos días peleando con esta vaina y me voy a tomar una copa